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How to Use This Manual
This manual provides full information and instructions for installing and
using Mail-it.

This introductory chapter begins with a brief overview of Mail-it and
then gives full instructions for installing Mail-it on your PC. Following
this there is a section giving some background on how Mail-it fits in with
the latest developments in mail systems, and looking forward to planned
enhancements that will enable you to take advantage of emerging stand-
ards and technology.

Chapter 2 gives step-by-step instructions for the basic operations you need
for everyday use of Mail-it. It will enable you to become familiar with the
overall structure and operation of the application, so you should have no
difficulty in finding and using the more specialized information given in
the reference chapter.

Chapter 3 is a complete reference to Mail-it, beginning with the use of
Mail-it to send messages from other applications, then describing each of
the subwindows used within the Mail-it application itself. A section on
the toolbar is then followed by a systematic description of each of Mail-it’s
menu commands, going through each menu and menu command in turn.

Chapter 4 tells you how to create Mail-it “tasks” to automate actions that
you need to carry out frequently, or actions that involve a large number of
messages.

Finally, two appendices cover technical details that may be required by
network or systems managers for configuring Mail-it to a particular
installation. The first appendix covers the Mail-it Control Panel item,
which is used to install new users and configure Mail-it’s messaging
subsystem. The second appendix contains information about user-defined
conversion files. These can be used to define conversions between the
messages sent over the Internet (MIME messages) and those produced and
viewed on the PC (MAPI messages).

One of the main objectives in developing Mail-it is that it should be easy
to use, so the defaults it provides for conversions and most configuration
parameters will be suitable for most installations. The appendices are
provided for experts who want to tune or modify the way their system
works in order to cater for particular specialized needs; ordinary users of
Mail-it can safely ignore the information in the appendices.
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Overview
Mail-it is a complete mail system running on PCs connected to an
internet (including the Internet) through an open standards mail server. In
many installations the server will be running UNIX, but it could also be
DOS, OS2, NT, VMS or a mainframe operating system running TCP/IP
protocols.

Because Mail-it implements the Internet’s MIME standard, you can send
virtually any type of data across the Internet.  You can send spreadsheets,
formatted text, graphics, sound clips or any of the many other types of file
you work with. The MIME standard is also backwards compatible, so you
will be able to send simple mail messages to users who do not have a
sophisticated MIME-compliant mail system such as Mail-it.

Mail-it also allows you to send mail directly from any of the increasing
number of applications conforming to Microsoft’s MAPI standard. With
MAPI, sending Mail is as simple as printing: all you have to do is select
Send from the application’s File menu.

As well as being able to send mail from other applications, you can use the
Mail-it application itself to compose messages and to attach files to send
with messages. When you receive mail, you can use Mail-it to read simple
messages and view attachments by launching other applications. Mail-it
also has commands for replying to messages, forwarding them to other
people, and re-sending them as attachments to another message.

When you receive messages they are placed in the In-tray folder in Mail-
it’s message store. If you just left them there, you’d soon have so many
that it would be difficult to find them again. Mail-it provides an extensive
range of commands to help you organize your messages in the message
store.

Mail-it allows you to set up “tasks” – automated actions or series of
actions. Tasks make it easy to carry out actions you need to repeat fre-
quently, or actions that you may only want to carry out once, but involve
a large number of messages.

Finally, Mail-it provides many options allowing you to customize it to
your own way of working. As just a few examples: you can change the
fonts it uses; decide whether messages wrap round to new lines when they
reach the edge of a window; create template forms for types of messages
you send often; and add signatures to messages automatically.

INTRO.PM5 19/06/95, 13:002



Introduction and Installation

1-3

Installing Mail-it

System requirements

To run Mail-it you must have:

• an IBM-compatible PC with an 80386 processor or higher,

• Microsoft Windows 3.1 or later,

• at least 4 Mbyte of memory installed in your PC,

• at least 5 Mbytes of free hard disk space,

• a Winsock compatible TCP/IP stack,

• a mail host running SMTP and either POP-2 or POP-3 – these
are provided free of charge on most UNIX systems.

Installation

The following installation instructions refer to standalone Mail-it installa-
tion only. If you are installing Mail-it as part of the PIPEX Dial product,
ignore this section and refer instead to the installation section of the
PIPEX Dial manual. Installing PIPEX Dial will provide default settings for
the various Mail-it installation options and will set up mail user details
using the PIPEX Dial user name.

Before installing Mail-it you should read the release notes on the installa-
tion disk for any developments since the manual was printed.

There are two ways to install Mail-it:

• as a full independent installation on your PC;

• as a network installation sharing an installation on a file server.

Both methods use the same disks and installation program.

If you are going to use a network installation, you will need to know
where Mail-it has been installed before you install it on your PC.

To install Mail-it on your PC:

1 Put the first installation disk in your floppy disk drive.
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2 To run the installation program:

Select Run from Program (or File) Manager’s File menu, type
A:\SETUP.EXE into the Command Line box and press OK.
(This assumes your floppy disk drive is Drive A.)

or

Open a File Manager window onto your floppy disk drive and
double-click on SETUP.EXE.

Whichever method you use, the first Unipalm Mail-it Setup
Program dialog box will be displayed:

3 Press Exit if you change your mind about installing Mail-it,
otherwise press Continue to display the Installation Options
dialog box:

4 Click on a radio button to show whether you want to install a
standalone version of Mail-it or share a copy over the network.

5 Press Continue.
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The dialog box that is displayed depends on whether you are
installing a standalone or network version.

6 For a standalone installation, the dialog box will be

Enter a path for the directory you want to use to hold your Mail-it
application files, or use the default. Press Continue to continue
the installation, or Back if you change your mind about a
standalone installation and want to return to the Installation
Options dialog box.

For a network installation, the dialog box will be

Enter the path for the directory holding the Mail-it application files
you want to share and press Continue to continue with the
installation, or Back if you change your mind about a shared
network installation and want to return to the Installation
Options dialog box.

As the installation continues you will be asked to change disks when
required. If your system already has a copy of the MAPI.DLL file installed
(for example if you are running Windows for Workgroups), the installa-
tion program will inform you that it is renaming it so that you can use
Mail-it’s MAPI.DLL file.

 Once you have installed Mail-it, you will need to use the Mail-it Control
Panel item to install users. Each user has an individual mail configuration,
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message store, etc, so several users can be installed independently on the
same PC.

To install a user on to the PC:

1 Double-click on the Windows Program Manager Control Panel
icon. This is in Program Manager’s Main group by default.

2 Double-click on the Mail-it Setup icon in the Control Panel
program group:

This displays the Mail-It Messaging Subsystem logon dialog
box:

In order to maintain the security of your mail system, the configuration of
the messaging subsystem is protected by a password.

To log on to the messaging subsystem as a new user:

1 Enter the name you want to use as your identifier.  You will be
asked if you want to create a new user with the name you entered:

2 Press Yes to display the Add a New User dialog box:
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3 Enter a path for the directory you want to use to keep your
signature files, forms and user configuration information.

4 Press OK to display the Configure Mail-it Messaging Subsys-
tem dialog box:

The Configure Mail-it Messaging Subsystem dialog box is the
entry point to a range of configuration options. These are de-
scribed in detail in Appendix A. For most installations the default
values for most options will be suitable, so only those that most
users may need to set are covered here – consult Appendix A if
you need more information.

5 Press OK when you have completed the configuration.

Password configuration

The Password box allows you to change your password for the Mail-it
messaging subsystem. To change your password:

1 Delete your current password – it will appear as a row of *s so that
other people cannot see what it is.
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2 Type in your new password – it will also appear as a row of *s,
again so that other people cannot see what it is.

3 When you press OK to close the dialog box, you will be asked to
type in your password again to check that you typed it correctly.

Address book configuration

To set up your address book

1 Press Setup in the Address Book box of the Configure Mail-it
Messaging Subsystem dialog box to display the Address Book
Provider Setup dialog box:

2 Type in the path for the directory that you want to hold your
address book.

3 Press OK to close the dialog box and return to the Configure
Mail-it Messaging Subsystem dialog box.

Transport configuration

Pressing Setup in the Transport box of the Configure Mail-it Mes-
saging Subsystem dialog box displays the Mail-it Transport Setup
dialog box. This can be used to configure your login credentials and mail
transport protocols. This is not normally required, but can be used to
optimize the transport: see Appendix A for more details.

Message store configuration

To set up your message store:

1 Press Setup in the Message Store box of the Configure Mail-it
Messaging Subsystem dialog box displays the Mail-it Local
Message Store Setup dialog box:
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2 Type in the path for the directory you want to hold your message
store.

3 Click Address Book Auto Update if you want the address of
someone sending you mail for the first time to be automatically
added to your address book. For more information, see the
“Address Book” section in the next chapter.

4 The default settings for the way MIME messages are handled by
the message store are suitable in most cases, so you should not need
to change them unless you have unusual or very specific require-
ments. If you do need to change the settings,  press Setup MIME
to display a dialog box allowing you to change the configuration –
see Appendix A for details.

5 Press OK to close the dialog box and return to the Configure
Mail-it Messaging Subsystem dialog box.
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Current and Future Developments
Efficient access to information can often mean the difference between
success and failure in business. Fortunately, providing this access is
becoming easier, as several recent developments have meant that it is now
possible to produce mail systems directly addressing and meeting the
business needs of individuals and organizations. Communication is
necessary at all levels, not just locally within your own office but nation-
ally and internationally, and not just within your own organization but
with your customers, suppliers and associates. This level of communica-
tion is impossible without a global network using standards everyone can
use.

The Internet: a global network for everyone

The Internet has been established for many years and is the largest and
fastest growing global network in existence. Once connected to the
Internet, you can communicate directly with two million other installa-
tions, a number which is currently doubling every twelve months. More
and more organizations are connecting to the Internet for internal and
external communications. This growth has meant that there has been a
pressing need for better and more business-oriented electronic mail
programs to work with the Internet: Mail-it has been developed to meet
that need.

Connections: the world beyond your LAN

In order to send messages from your PC across the Internet, you must be
connected to the outside world in some way. Proprietary LAN-based mail
systems place their emphasis on mail communication within the LAN.
This works fine at the local level, as the systems are usually tightly inte-
grated and often provide rich functionality. The problems come when
you try to communicate beyond the local area. This usually means going
through a proprietary gateway to connect to a global network, such as the
Internet. This may work if the recipient uses the same proprietary gateway
and LAN system, but otherwise your mail gets reduced to the lowest
common denominator of the sender and receiver systems, which usually
means simple text messages only.

 Mail-it uses a different approach by connecting the client PCs on the
desktop directly to the server using standard Internet protocols. This
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removes the need for gateways altogether. Not only does this save you the
initial cost of buying a gateway, it also eliminates the further costs of
maintaining and upgrading it. Removing the restrictions imposed by a
gateway means you can send the information you want to send, not just
the information the mail system allows you to send.

MIME: mail is more than words

There is an increasing need to communicate an enormous variety of
information at both the local and global levels. For example, regional
offices often need to report monthly sales figures to head office. How
much easier it would be if they could mail the data as a spreadsheet for
consolidation with other regions’ reports. When you submit a proposal to
a client, you need to use your company’s corporate style with appropriate
logos, fonts, layout and with different styles for headings etc. If your
customers are overseas, you will have to use the character set for their
language and not just English.  You will probably want to incorporate
diagrams and pictures, and even sound and video clips.

Until recently, the Internet provided no standard mechanism for carrying
messages with these features. The introduction of the MIME (Multipur-
pose Internet Mail Extensions) standard, means that you can now send
virtually any type of data across the Internet, provided your mail software
is MIME compliant. Mail-it is a full implementation of the MIME
standard, allowing you to send and receive complex multi-component,
formatted text and multimedia messages.

An important feature of MIME is that it has been designed to follow
existing Internet standards. This means that MIME messages can be
received by any existing Internet installation. Existing mail-readers
developed before the MIME standard was introduced will be able to
receive your MIME messages, and, at the very least, they will be able to
read the text part of messages and allow the non-text components to be
extracted for processing by other software.

MAPI: sending mail directly from your applications

Once you’ve made the connection between the desktop and the rest of
the world, you’ll want to write messages and send them. At the simplest
level, Mail-it provides a window for composing and editing text messages.
You can also use this window to attach files produced in other applica-
tions. This is fine if you just want to send a quick message or reply to
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someone else’s message. However, if you want to send, for example, a
spreadsheet in this way, you would have to create the spreadsheet file in
the spreadsheet application, save it, start up Mail-it, attach the spreadsheet
file and then send it. What you really want to be able to do is just send the
message straight from the spreadsheet application, or word processor,
DTP system, paint program, presentation package, project management
package or database. Mail-it’s solution to this problem is to use MAPI
(Messaging Application Programming Interface), which is Microsoft’s
messaging standard. Applications, such as spreadsheets or word processors,
that have been written to the MAPI standard are called MAPI-aware,
since they know how to use MAPI-based mail systems like Mail-it to send
mail.

The MAPI standard defines how applications and mail systems relate to
each other through the Windows operating environment. Provided you
are using a MAPI-based mail system, such as Mail-it, all you need to do to
send mail from a MAPI-aware application is select Send from its File
menu.

The benefits of using MAPI do not end there. Not only does MAPI
define how applications and mail systems should work together, it also lays

Other Applications:
Spreadsheets

Word processors
etc

Mail-it
Application

MAPI

Mail-it
Message Store

Mail-it
Transport Service

Mail-it
 Address Book

Mail Server

Mail-it Messaging Subsystem
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down how different components of a mail system are related. The diagram
shows how the separate components of Mail-it are held together by MAPI
interfaces.

Each of the components is a separate module. If you wish, you will be
able to add additional modules to complement those supplied with Mail-
it. So, for example, the Transport Service supplied with Mail-it provides
the protocols linking it to the Internet. If you wanted, you could add a
module from another supplier to give a LAN-based system, while retain-
ing all the other Mail-it components. The MAPI subsystem would then
select the transport service appropriate for the address of individual
messages. Another possibility is to add your own internally developed
corporate address server. Provided the individual components are built to
the MAPI standard, you can mix and match them to build a system that
fits your individual requirements.

The future

One of the most important considerations underlying the design and
development of Mail-it has been the adoption of widely accepted open
standards, such as the Internet, MIME and MAPI. This policy ensures that
the system is not tied to proprietary systems, so you can be assured that it
will not become obsolete. Future versions of Mail-it will reflect the
continuous development of existing standards and the introduction of new
ones.
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Introduction
Once you have installed Mail-it (see “Installation” in the previous chapter)
and, if necessary, configured it for your particular system (see Appendix
A), you can use Mail-it to send and receive messages. This chapter
introduces you to using Mail-it by giving step-by-step instructions for its
basic operations. Once you have read through this chapter and mastered
the operations it describes, you should have no difficulty in using the
reference chapter to find out about the more advanced features and
configuration options that are not covered here.

The reference chapter gives a complete description of all Mail-it’s com-
mands and operations. The appendices include information about
configuring Mail-it’s underlying messaging subsystem: the majority of
these settings require a good knowledge of how your network and mail
system are set up, so it is recommended that the configuration options
covered there are used only by systems or network managers.

This chapter shows you how to:

• start up the Mail-it application;

• compose, send and read simple messages;

• attach files to messages you send, and view the attachments to
messages you receive;

• reply to, forward and re-send messages;

• organize your messages in Mail-it’s message store;

• customize the appearance of messages;

• create and use personalized signatures and forms to use as
message templates;

• send mail from other applications;

• create a simple automated task.
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Starting up Mail-it and the Main Mail-it Window
To start up Mail-it from within PIPEX Dial:

Press E-Mail in the PIPEX Dial control panel.

To start up standalone Mail-it:

1 Double-click on the Mail-it  group icon in the Program Manager
window.

2 Double-click on the Mail-it icon in the Mail-it group.

If this is the first time you have started Mail-it in this session, the
Mail-it messaging subsystem will be started up and a new icon will
appear on your screen:

You can think of the Mail-it messaging subsystem as a sort of mail
van linking the mail system on your PC with the mail server (the
post office).

(MAPI-aware programs also use this subsystem, so if it is not
already running, it will have to be started up by the MAPI-aware
application before you will be able to send mail. Some applications
may launch the messaging subsystem when you start them up;
others may wait until you first send a message.)

If you are running Mail-it outside PIPEX Dial, you will be asked
to log on to the messaging subsystem:

3 Enter your logon name and password.

GETSTART.PM5 19/06/95, 12:222



Getting Started

2-3

If you haven’t already been installed as a Mail-it user, you should
consult Chapter 1 to find out how to install yourself, or contact
your systems or network manager to do it for you.

The main Mail-it window opens:

All of Mail-it’s commands can be used by selecting them from the menus
in the menu bar at the top of the window, but those you use most often
can also be run using buttons in the toolbar beneath the menus. The
reference chapter gives full details of all of Mail-it’s commands and
buttons.

When you use Mail-it, you work with sub-windows inside the main
Mail-it window.  You can manipulate these windows like any other
windows: you can move them, resize them, maximize them, minimize
them and, with one exception, close them. The one sub-window you
cannot close is your local message store – this is the only sub-window you
will see the first time you start Mail-it.  You will learn more about using
the message store and message list windows in the “Organizing your
messages” section later in this chapter.

The rest of this chapter introduces you to several other types of Mail-it
window; you can find full details for using all of Mail-it’s windows at the
beginning of the reference chapter. The first Mail-it window you will
look at in more detail is the compose window, which you use to write and
assemble messages before sending them.
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Writing, Sending and Reading Simple Messages

Writing a simple message

You use compose windows to send messages from within Mail-it.  You
can use them to assemble complex multi-part messages using a variety of
custom features, or, as in this first example, to send very simple messages.

To open a new compose window:

Press the new message button in the toolbar;

or

Select New Message from the Message menu.

To try out Mail-it, you can send yourself a message:

1 Enter your mail address in the To box (normally, of course, you
would enter someone else’s address).

2 Enter a brief description of the message in the Subject box.

3 If you want to send someone else a copy of your message, enter
their mail address in the Cc field. If you put your own address in
the Cc field, you will receive a copy as well as the original.

4 Type a message in the main body of the window:
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Note that the Edit menu has all the usual Windows commands for
copying, cutting and pasting text between windows in Mail-it and
other applications. However, this version of Mail-it only supports
plain text in the body of messages, so if you paste formatted text
from another application, the formatting will be lost. You will learn
how to send formatted documents as attachments later in this
chapter.

5 Press Send to post the message.

When you send the message, Mail-it uses an animation to show the
message being put in an envelope and posted, though you can turn this off
using Options/Environment in the Custom menu if you prefer.

After you have posted the message using Send, the Mail-it messaging
subsystem will send it – immediately if your PC is connected to the
Internet; otherwise, the message will be stored and sent next time you
connect and run Mail-it. You will be able to see when the message is sent,
as the mail van icon changes as the mail is actually being sent:

Send yourself another message using a different entry for the Subject so
that you will be able to try out moving between messages when you find
out about reading messages in a later section.
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HINTS: In this example you entered the addresses directly by typing
into the text boxes. Later in this chapter you will see how you can use
Mail-it’s address book to help with this – see the “Address book”
section.
You also saw how you could send yourself copies of the messages you
send using the Cc box. There is, however, an easier way of getting
copies automatically, by using Options/Compose Options in the
Custom menu or Local Compose Options in the compose window
– see the section on “Organizing your messages” later in this chapter.
You can also choose to close the compose window automatically after
you have sent a message, again using Options/Compose Options in
the Custom menu or Local Compose Options in the compose
window.

Checking for new mail

Mail-it checks regularly for any new mail arriving for you on the mail
server. When it finds there is new mail, it downloads it to your local
message store.  While this is happening, the Post Office icon changes to:

If you have unread mail stored in Mail-it, the new mail button in the
Mail-it window changes from

to

and if Mail-it is minimized, the Mail-it icon changes from

to

To check for new mail if you don’t want to wait for Mail-it to do one of
its regular checks or if you have disabled regular checks (see Appendix A ):

press the new mail button;

or

select New Mail? from the Message menu;
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or

select New Mail? from the Mail-it control menu. This is useful
when Mail-it is minimized, since clicking on the icon displays
the control menu, so you can check for new mail without having
to restore the Mail-it window.  You can also display the control
menu by clicking on the Windows control box at the top left of
any Mail-it window, but if Mail-it is not minimized, it is
probably easier to use the new mail button or New Mail? from
the Message menu.

The Post Office icon changes while it is looking for new mail:

HINT: You can set how often Mail-it looks for new mail using the
configuration options in the Control Panel – see Appendix A.

Finding your message in the local message store

When new mail arrives, Mail-it puts it into your local message store. If
your local message store is minimized, restore it by double-clicking on it
or by using the control menu. When you first start Mail-it, the message
store already contains a number of folders:

• Mail-it uses the In-Tray folder to store messages as they arrive
on your PC;

• Mail-it uses the Out-Tray folder as a temporary store for
messages you have posted before they are sent to the mail
server;

• Mail-it uses the Sent folder as the initial default folder for copies
of messages you send.
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Your local message store must always have In-Tray and Out-Tray folders,
but you do not need to save messages you send, or you can save them
somewhere else instead of the Sent folder.

The “Organizing your messages” section later in this chapter will show
you how to use the message store to organize your messages. For the
moment all you need to do is use it to find the message you sent, so that
you can read it.

1 Select the In-Tray folder.

2 To open a message list window for the In-Tray folder:

press the open folder button in the toolbar;

or select Open in the Folders menu;

or double-click on the In-Tray folder’s icon in the message store
window.

The icon for the folder in the message store window will change to an
open folder to show you that you have opened the message list window
for that folder, and a message list window will be opened:

The message list window will show you all the messages in your In-Tray
folder. If you sent yourself Cc copies, the message list window will contain
these as well as the other messages you sent yourself. If you open a message
list window for the Sent folder, you will see it also contains a copy of the
messages you sent. However, unlike a Cc copy, this is saved directly to the
message store and does not travel to the mail server and back.

Once you have opened a message to read it, its icon changes from

        to        
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Reading a simple message

To read a message in a folder:

1 Select the message in the message list window.

2 To open a read window for the message:

press the read message button in the toolbar;

or select Open in the Message menu;

or double-click on the message’s icon in the message list
window.

You can repeat the same process to read another message in a new read
window. However, if you just want to read the next message listed in the
message list window in the same read window:

press the next message button in the toolbar;

or select Next in the Message menu.

If you want to go back to reading the previous message:

press the previous message button in the toolbar;

or select Previous in the Message menu.
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Sending and Viewing Attachments

Sending a message with an attachment

So far you have learned how to send and read a simple message. However,
you will often want to send more complex documents such as word-
processed files with formatting, spreadsheets or graphics. By making use of
the MIME and MAPI standards, Mail-it enables you to send these types of
document as attachments.  You can attach any sort of file to a Mail-it
message, but this example uses a graphics file produced in Windows
Paintbrush, as you will probably have it installed on your PC. If you do
not already have a convenient Paintbrush file to attach to a message, create
one now (see your Windows documentation for information on using
Paintbrush).

To send an attachment to a message:

1 Open a compose window and fill in the To, Subject and Cc
fields, as you did for the simple message, and type a covering note
in the body of the compose window if required.

2 Press Attach to display a standard Windows Open file dialog box:

3 Use the dialog box to select the file to be attached to your message.

4 Press OK to close the dialog box. The file will be added to the list
of attachments in the Attachments drop-down list box.

5 If you want to add any more files, repeat 2–4.

You can choose to include the contents of the file itself in the message, or,
if the person you are sending the message to has access to the files as well,
you may want to send just the filename.
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1 Select the attachment from the Attachments drop-down list box
to display the Attachment dialog box:

The File box shows the name of the selected attached file.

2 In the Attachments Options box:

Click on Include Data in Message if you want the contents of
the file sent with the message

Click on Just Send Filename if you want to send the filename
only and not the contents of the file – you could use this option if
you were sending the message to someone who also has direct
access to the file on your network.

Click on Automatic if you want Mail-it to decide whether to
send the contents of the file or just the filename depending on the
location of the file and the recipient of the message.

Press Delete if you want to delete the attachment.

3 Press OK to return to the compose window.

When you have set up the attachments as you want them, press Send.

Reading a message with an attachment

To read a message with an attachment:

1 Open a read window for the message in the same way as you did
for the simple message:
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Any attachments to the message are listed in the Attachments
drop-down list box.

2 Select the attachment in the Attachments drop-down list box to
display the read Attachment dialog box:

The dialog box shows the type of attachment (its DOS extension).
The icon displayed beside the Type box is the application in
which the attachment was created: in this case it is the icon for
Windows Paintbrush.

Mail-it can only display the icon if the application is installed on
your computer and the attachment type is recognized, by being
associated with the application in the Windows registration
database: see your Windows documentation for information. If the
file type is not recognized, a “binary file” icon:

will be displayed and the View Using box will show the viewing
application as [NONE].
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3 If you want to view an attachment that does not have a recognized
file type in some application, or if you want to view a recognized
attachment using a different application, enter the filename (and
path) of the application in the View Using box. In this example,
you should leave it unchanged, provided you have Paintbrush
installed.

4 Press View to open the View Using application (Paintbrush in
this example) with a copy of the attachment loaded as a read-only
document.

You will be able to use this method to view the attachment even if only
the filename was sent in the attachment provided the file is accessible with
the same path from the receiver’s and sender’s PC.

Note that as the attachment is opened as a read-only file, you will not be
able to edit it in the viewing application, though you may be able to save a
copy under another name and then edit it. Alternatively, you can save the
attachment to a file in the Attachment dialog box.

1 Press Save in the Attachment dialog box to save an attachment to
a file by displaying a standard Windows Save As dialog box:

2 Fill in the details of where you want to save the attachment and
press OK.

Note that if you want to save the body of a message to a text file, use Save
As in the File menu to open a Save As dialog box. Whether the header is
saved with the message depends on whether you set Save Header When
Saving Text Files using Options/Environment in the Custom menu.
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Replying to, Forwarding and Re-sending Messages

Replying to a message

You will often want to reply to messages you are sent. Mail-it can auto-
mate this process to some extent by filling in the To, Cc, and Subject
fields of a compose window for your reply, and, if you choose, include the
original message you were sent.  You won’t often want to include the
whole of the original message in your reply, but it is often useful to
include parts to set the context for your reply. For instance, if the original
message asked some questions, you might want to include them as a
preface to your answers. If you do include parts of the original message, it
is usually a good idea to distinguish them in some way, and Mail-it allows
you to do this automatically.

To customize how replies should be sent:

1 Choose Options/Reply Options in the Custom menu to
display the Reply Options dialog box:

2 Type in any text you want to appear before the included original
message in the Reply Prologue String text box.  You might
enter some standard covering text or just a string of repeated
characters such as *, ̂ , or _ to separate off quotes from the message
you are replying to from your own text.
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3 Type in any text you want to appear after the included original
message in the Reply Epilogue String text box.  You might
enter a string of repeated characters such as *, v, or _ to separate off
quotes from the message you are replying to from your signature,
or other text following the quotes.

4 Type in any characters you want to appear at the beginning of each
line of the included message in the Reply Indent String text box.
This is probably the most useful facility as it marks all the lines in
the original so you can intersperse your own text and it remains
clear which lines are quotes from the original. A common conven-
tion is to use “>” as an indent string. Readers can then identify
forwarded text easily. “<” is often put before lines written in
response to “>” lines. When replies are made to replies several
levels of “>” can build up allowing the order in which the conver-
sation was conducted to be seen.

If you want to put information about the original message in these
strings, you can include:

, which will be replaced by the name of the original
message’s sender;

, which will be replaced by the date the original message
was submitted; and

, which will be replaced by the subject title of the
original message.

The settings for these strings will be used whenever you reply to a message
and opt to include the original in your reply. The Reply Button radio
buttons allow you to decide what happens if you press the reply button to
prepare a reply (you can also use the Reply command in the Messages
menu, but these settings have no effect in that case: see later in this
section).

5 To set how replies should be treated when you use the reply
button:

Click on Reply To Sender if you want the reply sent to the
sender only.

Click on Reply To Sender/Include Message if you want
the reply sent to the sender only and you want the reply to
include the original message.
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Click on Reply To All if you want the reply sent to the sender
and anyone else who was on the Cc list and received a copy of
the original.

Click on Reply To All/Include Message if you want the
reply sent to the sender and anyone else who was on the Cc list
and received a copy of the original, and you want the reply to
include the original message.

For this example, use the second option, as shown in the picture in
step 1.

Now that you have set up how replies should be treated, you can send a
reply to a message:

1 Select the message in a message list window, or if it is displayed in a
read window, select it there.

2 Either:

press the reply button;

or  choose Reply in the Message menu to display the submenu:

If you use the reply button to carry out this command, you are not
presented with this submenu; the selection you made in the Reply
Options dialog box is used.

For this example, to get the same effect as if you had pressed the
reply button, choose Sender/Include Message if you use the
menu command.
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A compose window will open for you to write the reply:

The To and Cc text boxes are filled in according to the command
you selected, the Subject field is the same as in the original
message, and, since an Include Message command was selected,
the body of the message contains a copy of the original message
with the reply prologue string, reply epilogue string, and reply
indent strings added appropriately.

3 Edit the message for your reply.  You can also edit the included
original message – generally you will only want to include short
quotations from the original to set your answer in context. The
window is a standard compose window, so you can use any of the
editing and menu operations that can be applied to messages in a
compose window.

Forwarding and re-sending messages

As well as replying to messages you are sent, you may often find that you
want to send it on to someone else. There are two ways of doing this: you
can “forward” the message, which means that the original message is
included in the body of the forwarded message and any attachments as
attachments; or you can re-send the message, which means the original,
and its attachments, are re-sent as attachments to the re-send message.
Another difference between forwarding and re-sending is that you can re-
send several messages at the same time as attachments to the re-send
message.
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When you forward a message, the original message is included in the body
of the forwarded message, so, as with replying to a message, you may need
to distinguish the original from any covering text you add.  You can use
Options/Forward Options in the Custom menu to set the Forward-
ing Prologue String, Forwarding Epilogue String, and Forwarding
Indent String in a similar way to that described for replies in the previous
section.

To forward a message to someone else:

1 Select the message in a message list window, or if it is displayed in a
read window, select it there.

2 Choose Forward in the Message menu to open a compose
window with the selected message included and the forwarding
prologue string, forwarding epilogue string, and forwarding indent
strings added appropriately.

3 Fill in the To and Cc text boxes with the addresses of the people
you want to forward the message to.

4 Edit the forwarded message, if required, and add any covering text.

5 Press Send in the compose window.

To re-send messages to other people:

1 Open the message list window containing the messages you want
to re-send.

2 Select the message, or group of messages, using the normal Win-
dows techniques of Ctrl-click to add isolated messages to a selec-
tion or Shift-click to extend a range of selected adjacent messages.

3 Choose Re-send in the Message menu to open a compose
window with the selected messages as attachments.

4 Fill in the To and Cc text boxes with the addresses of the people
you want to re-send the message to.

5 Add any covering text to the body of the message.

6 Press Send in the compose window.
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Organizing Your Messages
When you begin to accumulate a large number of messages you will want
to organize them in your message store.  You can create new folders to
hold messages, and move messages between folders.

Initially the message store only has the In-Tray, Out-Tray and Sent
folders. These are all directly in the root folder of the message store folder
tree.  You can create new folders at any point in the message store tree to
make a hierarchy of folders, just like you can make a hierarchy of directo-
ries in Windows File Manager.

To create a new message folder:

1 In the message store window, select the folder into which you
want to put the new folder.

2 Select Create from the Folders menu to display the Create
Folder dialog box:

3 Type in a name for the folder – it can have up to eight alphanu-
meric characters.

4 Press OK.

The new folder will appear in the selected folder in the message store
window.  You can create any number of folders to match your own
pattern of working. Making hierarchies of folders, provided they don’t
become too deep, can make finding your messages again much easier:
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When you first start up Mail-it it has a Sent folder, which is used to store
messages you have sent. However, you do not need to use this folder; in
fact you can choose not to save them at all.

To set the default folder for saving messages that you have sent:

1 Choose Options/Compose Options in the Custom menu to
display the Default Compose Options dialog box:

This dialog box allows you to customize the way compose windows
behave and the way messages are sent: see the reference chapter for full
details. For the moment we are only concerned with how messages are
saved when they are sent.

2 Check Automatically Save To Folder if you want a copy of
messages you send automatically saved to a folder. Checking this
option displays the Select Folder dialog box:
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Select the folder you want to use for saving messages when they are
sent.

3 Press OK.

When you are sending a particular message, you may want to save it
somewhere else instead of the default you have set. To do this:

Press Local Compose Options in the compose window you are
using to compose the message. This displays the Local Compose
Options dialog box, which is nearly identical to the Default
Compose Options dialog box. Check or uncheck Automati-
cally Save To Folder, as required, and select the folder you want
to save the message in.

When messages first arrive they are placed in your In-Tray. This means
that this folder could accumulate very large numbers of messages unless
you delete ones you no longer need and store others that you want to
keep elsewhere.

To delete a message:

1 Select the message in a message list window, or if it is displayed in a
read window, select it there.

2 Either:

press the delete button in the toolbar;

or choose Delete from the Message menu.

If Confirm on Delete When Deleting is set using Options/
Environment in the Custom menu, you will be asked to confirm
that you want to delete the message, otherwise the message will be
deleted without further prompting.
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To move a message or several messages from one folder to another:

1 Select the message(s) in a message list window, or if you only want
to move one message and it is already displayed in a read window,
select the read window.

2 Either:

press the save to folder button in the toolbar

or select Save Message(s) to Folder in the Message menu to
display the Save to folder dialog box:

3 Check Close After Filing if you are saving the message from an
open read window and want to close that window once you have
saved it.

4 Check Move Message(s) if you want to delete the messages from
their current folder when they are saved in the new folder. If you
leave this option unchecked you will make a copy of the original
message but leave the original in its original folder.

5 Select the target folder to move (or copy) the message(s) into.

6 Press OK to move (or copy) the messages into the selected folder.

Alternatively, you can use drag and drop to move or copy messages
between folders:

1 Make sure that a message list window showing the messages you
want to move is visible on the screen. Also ensure that either a
message list window for the folder you want to move them to is
open, or that the folder is visible in the message store window.
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2 Select the message(s) you want to move in their message list
window.

3 If you want to move the messages, hold Shift and drag the messages
to the new folder or message list window; if you want to copy the
messages, hold Ctrl and drag the messages to the new folder or
message list window. (See the Options/Environment command
in the Custom menu section of the reference chapter for control-
ling the effect of dragging without holding Shift or Ctrl.)

You may find that drag and drop is the most convenient way of moving or
copying messages when you want to spend a session reorganizing your
message store.  You can also use drag and drop to move and copy folders
in the message store window as an alternative to the Copy and Move
commands in the Folders menu.

On the other hand, the Save Message(s) to Folder command or button
is particularly useful when you are reading a batch of newly arrived
messages, as you can then save them to the folders you want to store them
in and delete them from your In-Tray as you go through them.
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Changing the Appearance of Messages

Changing fonts

You can change the way messages appear in windows in a number of
ways. First, you can change the font that is used:

1 Select Set Font in the View menu to display the screen Font
dialog box:

2 Select the typeface from the Font drop-down list box.

3 Select the type style from the Font Style drop-down list box.

4 Select the type size from the Size drop-down list box.

5 Press OK to close the dialog box and change the font used in the
selected window.

You can choose a different font independently for each window, the last
font set becoming the default used to display new windows when they are
opened. Note that the font you set will be used for the currently selected
window, but will not affect any other open windows. However, it will
become the default font used for any new windows of that type that you
open until you change the font again.

You may find that the font you want to use for the body of the text does
not work very well for the fields at the top of the window. If this is a
problem, you can choose Use Standard Font In Headers Box using
Options/Environment in the Custom menu.

Remember that some messages may require a particular type of font. In
particular, if they contain columns of figures or other formatting that
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depends on the position of characters, you should probably use a fixed-
width font such as Courier.

Using word wrap

Another factor that affects the formatting of text in read and compose
windows is whether you use word wrap or not. If word wrap is turned on,
text going beyond the edge of the window will be wrapped round to the
next line:

If it is turned off, the text will continue beyond the edge of the window
and you will have to use the scroll bar to see it:

You can set word wrap on or off for individual windows using Word
Wrap in the View menu. The default behavior for new read and com-
pose windows is determined by settings you can make in Options/Read
Options and Options/Compose Options, respectively, in the Custom
menu.

One additional consideration to bear in mind when you are using word
wrap in a compose window is that the word wrapping may mislead you
into thinking the lines actually end at the window’s edge. This is not
necessarily the case, and messages you send from a window with word
wrapping turned on may contain very long lines. Although the Mail-it
messaging subsystem will automatically break up the long lines for trans-
mission, these may not be where you would want to break them and this
might make the message difficult to read if the recipient’s mail system is
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not as sophisticated as Mail-it and cannot put the lines back together again.
To avoid this problem, you can make Mail-it insert real line breaks to
mirror the wrapped display in the compose window.  You do this by
setting Force Hard Returns using Options/Compose Options in the
Custom menu to set the default, or, for a particular message, using the
Local Compose Options dialog box displayed by pressing Local
Compose Options in the compose window.

Printing Messages

You can use Mail-it to print the body of messages; to print an attachment,
you have to open it in the viewing application (see “Reading a message
with an attachment” earlier in this section) and use the application’s print
command.

There are a number of options controlling how messages are printed. First,
you can choose whether to print header information with files using Print
Header When Printing Files using Options/Environment in the
Custom menu.

You can also choose which font to use for printing.

If you want to use the same font for printing as on the screen:

Choose Mirror Display Font in the View menu.

If you want to set a different font for printing:

Choose Set Printer Font in the View menu to display the Font
dialog box. Use this in exactly the same way as when you set the
font for the screen.

The printer font settings you choose will be the defaults used for printing
all messages until you change them again.

As well as setting the font and deciding whether to print the header with
the message, you can also give the pages of printout a header and a footer:

Choose Page Setup in the File menu to display the Page Setup
dialog box:
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Type into the Header and Footer boxes any text you want to
appear in the header or footer of the message when it is printed.
You can insert codes in the text to print information associated
with the message automatically. The codes you can use are:

&Name, to print the sender’s name;

&Date, to print the time and date the message was submitted;

&CurrTime, to print the time when the message is printed;

&PageNum, to print the page number;

&Subject, to print the subject of the message;

&To, to print the addressee of the message;

&Cc, to print the addresses of the people who were sent copies.

If you enter the text shown in the example, the subject of the message will
appear in the header and a page number in the footer.

Finally, you can change the printer setup using Print Setup in the File
menu. What this will enable you to do depends on what printer you have
connected: see your printer and Windows documentation if you need any
help using this dialog box.
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The Address Book

Building an address book

Email addresses can often be rather complicated, so you will not want to
have to remember them all. Mail-it provides an address book facility so
that you can store addresses and add them to the To and Cc fields in
compose windows.

To add names to your address book:

1 Choose Address Book in the Custom menu to display the
Address Book dialog box:

The Name scroll box shows you the names of all the people in your
address book, and the Address box the address of the currently selected
name.

To add a new name and address to the address book:

Press New to display the New Details dialog box:
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Type the name and Email address of the new entry into the
Display Name and Email Address boxes, and press OK.

To change an entry in the address book:

In the Name box, select the name of the person whose details you
want to change and press Edit (or double-click on the name), to
display the Edit Details dialog box:

The dialog box shows the current details held within the address book.

Change the details in the box, if required, and press OK.

To remove a name and address from the address book:

Select the name of the person whose address you want to delete
and press Delete.

If you have a large address book and you are not sure about a particular
name:

1 Press Search to display the Search dialog box:

2 Click on User Name if you want to search through the names in
the address book; click on Email Address if you want to search
through the addresses in the address book.
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3 Click Anywhere if you want to search for part of a name (or
address) anywhere within each name (or address) in your address
book; click Start if you want to search only the beginning of
names or addresses. For example, if you search for John and select
Anywhere, you will find not only John Smith but also Bill
Johnson; if instead you select Start, you will find only John Smith.

4 In the Search For box, type a part of the name or address that you
know is correct. For example, if you want to send a message to
Michael Jones, but you are not sure if he is in the address book
under Jones, Michael, or E M Jones, you should type in Jones to
search through all address entries with Jones somewhere in the
name.

5 Press Search Next to begin searching the address book. If a
matching name is found, it will be highlighted in the Name box in
the Address Book dialog box.

6 If this is the name you are looking for, press OK, otherwise press
Search Next again to look further down the list. Press Cancel to
give up the search.

Using your address book

Once you have entered addresses into the address book you can use them
in compose windows.

To add an address from your address book to the To or Cc field of a
compose window:

1 Press Address in the Compose window to display the Address
Book dialog box:
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2 In the Name box, select the name of the person you want to
receive the message. Press Add in the To box to transfer the
selected name to the To box. Repeat for any other people you
want to receive the message.

3 In the Name box, select the name of any person you want to
receive a copy of the message. Press Add in the Cc box to transfer
the selected name to the Cc box. Repeat for any other people you
want to receive a copy of the message.

4 If you change your mind about any of the names in the To or Cc
boxes, select the name in the box and press Remove.

You can also use the Address Book dialog box to search for names or
addresses, or add to, change or delete entries in the address book: the
procedures are identical to those described for building your address book.
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Creating and Using Signatures

Creating signatures to be added to your messages

When you send messages you will be identified to the recipient by the
From field in the header. However, this may not give as much informa-
tion as you want. For example you may want to include your company
position, address, telephone and fax numbers.  You can do this automati-
cally by creating a signature, which will be attached to the foot of your
messages.  You can create several signatures to be used in different
circumstances. For example, you may want a different signature for
internal and external mail, and another for personal mail. Mail-it allows
you to create as many as you like and nominate one, or none, as your
default, which will be added to a message unless you choose to use another
one.

Select Signatures from the Messages menu to display the Select
a Signature dialog box:

The scroll box lists all the signatures you have created. Initially it will just
have  (this entry is there so that you can set no signature as the
default). The * against one of your signatures marks it as your default
signature.

To create a new signature:

1 Press New to open a New Signature dialog box:
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2 Type in the text you want added to the end of your messages. The
text can be any length, but bear in mind that most people dislike
receiving mail with long or elaborate signatures.

3 Press OK when you have completed the signature, to open the
Enter Filename dialog box:

4 Type a name for the file in the text box. The name can be made up
of up to eight letter or number characters.

5 Press OK to close the dialog box and save the signature in a file
with the name you have given.

You can also save the contents of a signature to a text file using Save As in
the File menu.

The next time you select Signatures from the Message menu the Select
a Signature dialog box will show the name of the signature you have
created in the scroll box.

The Select a Signature dialog box allows you to choose a signature as
your default, and edit and delete signatures, as well as create them.

Choosing a default signature

To make a signature your default signature added at the end of messages:

1 Select Signatures from the Messages menu to display the Select
a Signature dialog box.

2 Select the signature in the scroll box.

3 Press Default to make the signature the default.

The default signature is marked * in the Select a Signature dialog
box.
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Making changes to a signature

To change an existing signature:

1 Select Signatures from the Messages menu to display the Select
a Signature dialog box.

2 Select the signature in the scroll box.

3 Press Edit to open a signature dialog box containing the signature:

4 Edit the signature.

5 Press OK to close the dialog box and save the signature.

Deleting signatures

To delete an existing signature:

1 Select Signatures from the Messages menu to display the Select
a Signature dialog box.

2 Select the signature in the scroll box.

3 Press Delete to delete the signature.

If you have set Confirm on Delete using Options/Environment in the
Custom menu, you will be asked to confirm that you want to delete the
signature.

Adding your signature to a message

If you have set a default signature, it will be added automatically to the end
of any messages you send, unless you decide to use a different one.

To add a different signature (or no signature) to an individual message in a
compose window:

Select the signature or  from the Signature drop-down
list box.
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Creating and Using Template Forms for Messages

Creating a form

There may be some messages you send frequently that have basically the
same content or structure, such as an expenses claim or an agenda for a
regular meeting. To save you from having to type in the common ele-
ments each time, you can create a template for the messages using Mail-it’s
Forms command, which allows you to create and manage forms.

To create a template form:

1 Select Forms from the Message menu to display the Select a
Form dialog box:

2 Press New to open a New Form dialog box:

You use the dialog box to build a template for the messages built
from the form. When you use the form the entries you make in
the header fields and the body of the form are copied into the
corresponding fields in a new compose window, which you can
then edit and use in the same way as any other compose window.
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3 If the messages built using the form will always be sent to the same
person, enter the address in the To text box.

4 If you want the messages built from the form to carry the same
subject description, enter it in the Subject field.

5 If the messages built using the form will always be copied to the
same people, enter their addresses in the Cc text box.

6 Enter into the main text window any text you want to appear in all
of the messages built using this form.

Remember that you will be able to edit any of these entries when
you use the form.

7 Press OK when you have finished designing the form to display
the Enter Filename dialog box:

8 Type a name for the file in the text box. The name can have up to
eight alphanumeric characters.

9 Press OK to close the dialog box and save the form in a file with
the name you have given.

You can also save the contents of a form to a text file using Save As in the
File menu.

The next time you select Forms from the Message menu the Select a
Form dialog box will show the name of the form you have created in the
scroll box.

The Select a Form dialog box allows you to edit and delete forms as well
as create them.
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Changing a form

To change an existing form:

1 Select Forms from the Message menu to display the Select a
Form dialog box.

2 Select the form in the scroll box.

3 Press Edit to open a dialog box containing the form:

4 Edit the form.

5 Press OK to close the window and save the edited form.

Deleting forms

To delete an existing form:

1 Select Forms from the Message menu to display the Select a
Form dialog box.

2 Select the form in the scroll box.

3 Press Delete to delete the form.

If you have set Confirm on Delete using Options/Environment in the
Custom menu, you will be asked to confirm that you want to delete the
form.
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Using a form as a template for a message

Once you have created a form, you can use it as the basis of a message.

To use a form:

1 Select Forms from the Message menu to display the Select a
Form dialog box.

2 Select the form in the scroll box in the Select a Form dialog box.

3 Press Use to open a compose window based on the form:

4 This is a normal compose window, so you can edit the header
fields and the body of the message, add any attachments you want
to send with the message, and add a signature if you don’t want to
use your default.
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Sending Mail from Other Applications
One of the major benefits Mail-it provides comes from it being based on
MAPI. This means that you can use it to send mail directly from other
applications, provided they are one of the increasing number of  “MAPI-
aware” programs. When Mail-it is installed, MAPI-aware applications
have an extra command on their File menu. This is the Send command,
which allows you to send the current document in a mail message.

Applications differ in how they use MAPI. Some will use it to send
messages in the body of a MAPI message, others as an attachment and
others may give you the choice.  Yet others may, for instance, send saved
documents as an attachment and unsaved documents in the body of a
MAPI message. Consult the application’s documentation or your supplier
for more information about how it actually behaves. If the message is
being sent as an attachment it will appear on the list of attachments in the
Attachments drop-down list box.

To send the current document in a MAPI-aware application in a mail
message:

1 Select Send in the application’s File menu to display the Send
Note dialog box:

This dialog box is very similar to a compose window, and is used
in much the same way.
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2 Fill in the Subject, To and Cc fields in the same way as you
would in a compose window.  You can also insert addresses into
the To and Cc fields by pressing Address to display the Address
Book dialog box, as in a compose window.

3 In the Bcc box, fill in the mail addresses of any people you want to
send copies of the message, but whose addresses you do not want
to appear on the recipients’ Cc list: use a semicolon “;” to separate
the addresses.

4 In the Note box, write any notes that you want to appear at the
beginning of the message you are sending.

5 Press Attach if you want to attach a file to send with the message.
A standard Windows Open file dialog box is displayed, which
allows you to select a file to attach to the message in the same way
as for a compose window.

6 If you want to delete an attachment or change the way an attach-
ment is sent, select the attachment from the Attachments drop-
down list box to display the Attachment dialog box.  You can use
this to delete attachments or change the way attachments are sent
in exactly the same way as when this dialog box is displayed from a
compose window.
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Creating a Task
Mail-it tasks allow you to automate a wide range of actions. The possibili-
ties are described in full in Chapter 4, but a simple example is included
here to demonstrate the basic ideas involved. The example task automati-
cally moves mail received from a particular individual into a folder. To
create a task to do this:

1 Select Tasks in the Custom menu to display the Task Manage-
ment dialog box:

The box lists any tasks that have already been defined: at the
moment, there are no tasks.

2 Press New to display the New Task dialog box:

The first step is to define the “trigger event” – when the task
should be carried out.

3 Press Select in the On Event box to display the Select the Event
Type dialog box:
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4 Select New Mail from the list, and press OK.

You are returned to the New Task dialog box, and New Mail is
shown in the On Event box. The next step is to decide which of
the messages to act on.

5 Press Add in the When Matching box, to display the Select a
New Match dialog box:

6 Select Sender from the list, and press OK to display the Sender
Contains dialog box:

7 Type “john” into the box at the top, and press Add.

The name now appears in the box below.
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8 Press OK to return to the New Task dialog box.

The next step in defining a task is to specify what should happen
when the trigger event occurs.

9 Press Add in the Perform Action box, to display the Select a
New Action dialog box:

10 Select Save to Folder from the list, and press OK to display the
Specify Folder dialog box:

11 Check Move Messages so that the messages are moved, not
copied.

12 Press Select to display the Select Folder dialog box:

13 Select the folder where you want the messages to be moved.

14 Press OK to return to the Specify Folder dialog box.

The final step is to give the task a name and description, and save
it.
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15 Press OK to return to the New Task dialog box.

16 Press OK in this dialog box to display the Save Task dialog box:

17 Type a description of the task into the Description box (this will
appear in the Task Management dialog box).

18 Type a file name (of no more than eight characters) for the task
into the File Name box, and press OK.

The Task Management dialog box now shows the new task and
its description. If you want to change any features of the task, select
it and press Edit. To close the dialog box, press Done.
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Introduction
There are two ways of sending mail using the Mail-it mail system. The
first is to compose and send the mail in the Mail-it application itself; the
second is to compose and send your message directly using another
application. This second method will only work if the application is
MAPI-aware; to send a document composed in an application that is not
MAPI-aware, you should save it and attach the file to another message
composed and sent by either of the two basic methods of using Mail-it.

The chapter begins with a section on sending mail from MAPI-aware
applications. The rest of the chapter is devoted to describing the Mail-it
application itself, beginning with a description of each of the windows you
use when preparing, reading or organizing your mail. These are

• the Mail-it application window;

• the message store window;

• message list windows;

• read windows;

• compose windows;

• form windows;

• signature windows.

There is then a short section on the toolbar and finally each of Mail-it’s
menus are described in turn, with instructions for using all the commands.

The appendices contain technical information, which in most situations
the average user can safely ignore. Appendix A provides system and
network managers with information on setting up and configuring the
Mail-it messaging subsystem using the control panel. Appendix B de-
scribes how you can specify additional conversions between MIME and
MAPI messages to cope with any unusual or specialized requirements; the
supplied default conversions will cover most cases you will encounter in
practice. The information in these appendices is provided for experts only,
so you should not make changes using the control panel unless you have a
good knowledge and understanding of your network and mail environ-
ment. Once Mail-it has been set up, there should be no need to make any
further changes to its configuration unless there are changes to the operat-
ing environment.
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Sending Mail from MAPI-Aware Applications
Once you have installed Mail-it, MAPI-aware applications will have an
extra command on their File menus. This is the Send command, which
you can use to send the current document in a mail message.

Applications vary in how they use MAPI to send messages. Some send
messages in the body of a MAPI message, some as an attachment and
others allow you to choose how they are sent. Another strategy used by
applications is for saved documents to be sent as an attachment and
unsaved documents as the body of a MAPI message. Consult the applica-
tion’s documentation or your supplier for more information about how a
particular application actually behaves.

To send the current document in a MAPI-aware application in a mail
message:

1 Select Send in the application’s File menu to display the Send
Note dialog box:

The message will appear in the Note box or in the Attachments
drop-down list box, depending on the strategy used by the applica-
tion.

2 In the To box, fill in the mail addresses of the people you want to
send the message to: use a semicolon “;” to separate the addresses if
there is more than one. Alternatively, press Address to display the
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Address Book dialog box to enter an address from your address
book: see the section below on using the address book.

3 In the Subject box, fill in a brief description of the message
contents.

4 In the Cc box, fill in the mail addresses of any people you want to
send copies of the message: use a semicolon “;” to separate the
addresses. Alternatively, press Address to display the Address
Book dialog box to enter an address from your address book: see
the section below on using the address book.

5 In the Bcc box, fill in the mail addresses of any people you want to
send copies of the message, but whose addresses you do not want
to appear on the recipients’ Cc list: again use a semicolon “;” to
separate the addresses.

6 In the Note box, write any covering notes that you want to appear
with the message you are sending.

7 Press Attach if you want to attach a file to send with the message.
A standard Windows Open file dialog box will be displayed:

Use the dialog box to select the file to be attached to your message.

Note that you can use the List Files of Type drop-down list box
to show All Files (*.*), or just Text Files (*.txt). You can also
choose which files are shown by typing an extension into the File
Name text box and pressing OK. For example, typing *.bmp
means that only the Windows Paintbrush files will be shown.

When you have selected the required file and pressed OK to close
the dialog box, the file will be added to the list of attachments in
the Attachments drop-down list box.
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8 If you want to delete an attachment or change the way an attach-
ment is sent, select the attachment from the Attachments drop-
down list box to display the Attachment dialog box:

The File box will show the name of the attached file.

a) In the Attachments Options box:

Click on Include Data in Message if you want the contents
of the file sent with the message.

Click on Just Send Filename if you want to send the filename
only and not the contents of the file – you could use this option
if you were sending the message locally to someone who also
has direct access to the file.

Click on Automatic if you want Mail-it to decide whether to
send the contents of the file or just the filename depending on
the location of the file and the recipient of the message.

b) Press Delete if you want to remove the attachment from the
message.

9 Press Send to send the message.

Note that if an application allows you to protect the security of a docu-
ment with a password, as Microsoft Word does for example, this security
will be maintained in the transmitted message. Future versions of Mail-it
will provide more systematic security features using the Privacy Enhanced
Mail standard.

The address book

To select addresses from your address book to fill in the To or Cc fields
when sending a message:
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1 Press Address in the Compose window to display the Address
Book dialog box:

2 In the Name box, select the name of the person you want to
receive the message. Press Add To to transfer the selected name to
the list of people to whom the message is to be sent. Repeat for
any other people you want to receive the message.

3 In the Name box, select the name of any person you want to
receive a copy of the message. Press Add Cc to transfer the
selected name to the list of people you want to send copies. Repeat
for any other people you want to receive a copy of the message.

4 If you change your mind about any of the people being sent the
message or a copy, select the name in the relevant box and press
Remove.

5 If you have a large address book and you are not sure about a
particular name, press Search to display the Search dialog box:
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6 Click on User Name if you want to search through the names in
the address book; click on Email Address if you want to search
through the addresses in the address book.

7 Click on Anywhere if you want to search for part of a name (or
address) anywhere within each name (or address) in your address
book; click Start if you want to search only the beginning of
names or addresses. For example, if you search for John and select
Anywhere, you will find not only John Smith but also Bill
Johnson; if instead you select Start, you will find only John Smith.

8 In the Search For box, type a part of the name or address that you
know is correct. For example if you want to send a message to
Michael Jones, but you are not sure if he is in the address book
under Jones, Michael, or E M Jones, you should type in Jones to
search through all address entries with Jones somewhere in the
name.

9 Press Search Next to begin searching the address book. If a
matching name is found, it will be highlighted in the Name box in
the Address Book dialog box.

10 If this is the name you are looking for, press OK, otherwise press
Search Next again to look further down the list. Press Cancel to
give up the search.

You can also use the Address Book dialog box to add to or change the
address book.

To add a name to the address book:

1 Press New to display the New Details dialog box:
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2 Type the new details into the Display Name and Email Address
boxes, and press OK.

To change an entry in the address book:

1 Select the name of the person you want to change the details for in
the Name box and press Edit to display the Edit Details dialog
box showing the current details:

2 Change the details in the Display Name and Email Address
boxes, and press OK.

To delete an entry from the address book:

Select the name of the person whose address you want to delete
and press Delete.
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The Mail-it Application Window

When you start Mail-it, the Mail-it application window is opened. This
window has the usual Windows control box at the top left-hand corner,
resize boxes at the top right and a menu bar below the title bar.

The toolbar, which is just below the menu bar, contains a number of tool
buttons. You can use these as a quick method of running commands
instead of selecting them from menus. For full details of how to use the
tool buttons, see the “Toolbar” section later in this manual.

The right-hand side of the status bar at the bottom of the window shows
whether Caps Lock, Num Lock or overwrite mode are enabled, and the
left-hand side shows help cues if you press the mouse button while the
pointer is over a menu command or tool.

You can choose to hide or display the toolbar and status bar using the
Toolbar and Status Bar commands in the View menu.

The Mail-it application window contains the document windows you use
for reading, composing and managing your messages. These windows can
be moved, resized and minimized using standard Windows techniques.
The screen picture shows the window with, from left to right, minimized
message store, message list, read, compose, form and signature windows.
The following sections describe how to use each of these windows in
turn.
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You can move between the windows in the Mail-it application window
by:

selecting the window using the mouse;

selecting the window from the list at the bottom of the Window
menu;

repeatedly pressing Ctrl and Tab together to cycle through the
windows until the one you require is selected.
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The Message Store Window

Future versions of Mail-it will allow you to use several message stores,
which you will be able to select using the drop-down list box at the top of
the message store window. The current version only supports one message
store, so the list box will only show your default message store.

The message store window shows the folders you use to hold messages in
your message store. Your message store must contain at least an In-tray,
and an Out-tray folder. The In-tray is used to hold new mail when it is
received from the mail server. The Out-tray is used to hold mail tempo-
rarily for the time between your sending a message and Mail-it actually
delivering it to the Mail server. When you install Mail-it there is also a
Sent folder which is the default folder used to hold mail after you have
sent it and it has been delivered to the mail server. You can choose not to
save sent messages or save them in another folder using Options/Com-
pose Options in the Custom menu or Options in a compose window.

Folders can contain messages or other folders in the same way that a
directory can contain files or other directories. Although you will probably
be able to identify the directories and files used to store Mail-it folders and
messages in your DOS directory structure, you should only use the Mail-it
commands and operations to manipulate folders and messages. If you use
another tool, such as Windows File Manager, you could cause an error in
Mail-it, as it keeps track of messages by storing additional information
about messages in the folder directory. You can use the Create, Copy,
Move and Delete commands in the Folders menu to structure your
message store. As a quick alternative, you can “drag and drop” folders:

To move a folder from one position in the tree to another:

1 Move the pointer over the folder you want to move.

2 Press and hold down the Shift key.
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3 Press the left mouse button and drag the folder into its new
position.

4 Release the mouse button and then the Shift key to drop the folder
into its new position.

To copy a folder from one position in the tree to another:

Drag the folder to the position you want a copy of the folder while
holding the Ctrl key down.

The effect of dragging without holding the Shift or Ctrl key depends on
how the Default Drag Operation is set using Options/Environment
in the Custom menu.

You can open a message list window to view a list of the messages in a
folder: see the next section for details.

The message store window shows you which folders are open by opening
the folder icon:

changes to

Closing the message list window changes the icon back.
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Message List Windows

The priority of a message is show by the color of the icon: urgent mes-
sages are red and outlined; normal priority messages are yellow; non-
urgent messages are gray.

Messages that you have already read will be marked with an open enve-
lope:

Messages that you have not read will be marked with a closed envelope:

Mail you have sent will appear on lists with an icon representing a sheet of
paper with writing:

You can open a message list window showing the messages held in a
folder by:

selecting the folder in the message store window and selecting
Open in the Folders menu;

selecting the folder in the message store window and pressing the
open folder icon in the toolbar;

selecting the folder in the message store window and pressing
Enter;

or

double-clicking on the folder in the message store window.

REFERENS.PM5 19/06/95, 12:3112



Mail-it Reference

3-13

The message list shows the sender of the message, the subject and the date
and time it was sent.

You can use message list windows for organizing your messages and
selecting the messages to be read, replied to, forwarded or re-sent: see the
information in the next section and Reply, Forward and Re-Send in the
Message menu for more information about how to perform these actions.

You can also use drag and drop to move or copy a message from one
message list window to another or to a folder in the message store win-
dow: see the previous section for information on using drag and drop.

You can close the currently selected message list window by:

clicking on the Windows control box at the top left-hand corner of
the read window to drop down the control menu, and then
selecting Close;

or

double-clicking on the control box.
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Read Windows

Note that the appearance of the read window is controlled by settings
made using Options/Read Options in the Custom menu, so your read
window may not look exactly like this picture.

You can open a read window for a message by:

double-clicking on the message in a message list window;

selecting it in a message window and using Open in the Message
menu;

or

selecting it in a message window and pressing the open message
button.

The amount of information shown at the top of the window depends on
how you have set the Header options using Options/Read Options in
the Custom menu. The picture shows a read window with Show as
Edit Box selected. This means that basic information about who sent the
message, what it is about, who it was sent to, who was sent copies and the
date it was sent is shown in a scrollable box. You can choose to show this
information in separate fields, which takes up more room, or show all the
information in the header in a scrollable box, though this contains more
detail than most people need.

The main area of the window contains the body of the message. If the
message is too wide to fit in the window, you can use the scroll bar at the
bottom to scroll the message in the window, or you can set Word Wrap
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so that a new line is started when the message reaches the edge of the
window: see Options/Read Options in the Custom menu and Word
Wrap in the View menu for more information.

You can use Copy in the Edit menu to copy text in the header informa-
tion or the main window, but you cannot cut, delete or edit it in any way.

The Attachments drop-down list box allows you to see if there are any
attachments to the message, and to view them.

To view an attachment to a message or to save it to a file:

1 Select the name of the attachment from the Attachments drop-
down list box to display the read window Attachment dialog box:

The dialog box shows the type of attachment by its DOS extension
and by an icon displayed beside the Type box. If an application for
viewing the attachment is installed on your computer and the
attachment type is recognized (by being associated with the
application in the Windows registration database: see your Win-
dows documentation for information), the application’s icon will
be displayed and the path to the application will be shown in the
View Using box.

If the file type is not recognized, a ‘binary file’ icon:

will be displayed and the View Using box will show the viewing
application as [NONE].

2 If you want to use another application to view an attachment that
does not have a recognized file type, or you want to view a
recognized attachment using a different application, enter the
filename (and path) of the application in the View Using box.

3 Press View to open the View Using application with the attached
file loaded as a read-only document.
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Note that as the attachment is opened as a read-only file, you will not be
able to edit it in the viewing application, though you may be able to save a
copy under another name and then edit it.

Alternatively you can save the attachment to a file in the Attachment
dialog box.

1 Press Save in the Attachment dialog box to save an attachment to
a file by displaying a standard Windows Save As dialog box:

2 Fill in the details of where you want to save the attachment and
press OK.

To close the currently selected read window:

Click on the Windows control box at the top left-hand corner of
the read window to drop down the control menu, and then select
Close.

or

Double-click on the control box.
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Compose Windows

Compose windows are used for writing and editing your messages before
you send them. You can open a compose window for a message by:

Selecting New Message in the Message menu

or

Pressing the new message button.

Compose windows are also used to reply to, forward and re-send messages
sent to you: see Reply, Forward, and Re-Send in the Message menu.
In these cases the text boxes at the top of the window are filled in appro-
priately when the window is opened.

To prepare a message before you send it:

1 In the To box, fill in the mail addresses of the people you want to
send the message: use a semicolon “;” to separate the addresses if
there is more than one. Alternatively, press Address to display the
Address Book dialog box to select addresses from your address
book: see the “Sending mail from other MAPI-aware applications”
section earlier in this manual for how to use this dialog box.

2 Type a short heading for the contents of the message in the
Subject box.
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3 In the Cc box, fill in the mail addresses of any people you want to
send copies of the message to: use a semicolon “;” to separate the
addresses. Alternatively, press Address to display the Address
Book dialog box to select addresses from your address book: see
the “Sending mail from other MAPI-aware applications” section
earlier in this manual for how to use this dialog box.

4 Type the body of the message in the main window area.

5 The Signatures box shows the selected signature to be added to
the end of the message. Initially this will show your default signa-
ture, if you have one. To choose another signature, select it from
the Signatures drop-down list box. To choose to add no signa-
ture, select [None] from the Signatures drop-down list box. If
you want to create a new signature, use Signatures in the Mes-
sage menu.

6 Press Attach if you want to attach files produced in other applica-
tions. A standard Windows Open file dialog box is displayed: see
the “Sending mail from other MAPI-aware applications” section
earlier in this manual for how to use this dialog box.

7 If you want to delete an attachment or change the way an attach-
ment is sent, select the attachment from the Attachments drop-
down list box to display the compose Attachment dialog box: see
the “Sending mail from other MAPI-aware applications” section
earlier in this manual for how to use this dialog box.

8 If you want to override the default options set using Options in
the Custom menu, press the Options button to display the Local
Compose Options dialog box:
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When the dialog box opens it will show the current default settings
for the compose options. Changing the settings in this dialog box
will override the default settings for this message only. The default
settings are made with Options/Compose Options in the
Custom menu using, with one exception, the same dialog box:
see Options/Compose Options in the Custom menu for full
details of how to use this dialog box.

The one difference between the Default and Local Compose
Options dialog boxes is that there is no Use Word Wrap check
box in the Local Compose Options. If you want to use word
wrap, and it is not set in the Default Compose Options dialog
box, select Word Wrap in the View menu.

When word wrap is selected Mail-it puts “soft returns” into the
text so that all of it fits within the width of the viewing window. If
you want to keep this formatting in the message you send, check
Force Hard Returns to replace the soft returns with real “hard
returns” in the transmitted message. If you do not force hard
returns and have long lines, Mail-it will break up the long lines into
shorter lines for transmission. However, these will not necessarily
be where you want line breaks, such as in the middle of a word,
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and if the receiver’s mail system does not remove the soft returns
and line breaks automatically, the message may appear rather
garbled.

9 When you have finished composing the message and setting any
options, press Send or select Send from the Message menu to
send it.

It isn’t possible to say exactly when the message will be sent to the mail
server as this is partly the responsibility of Windows and will depend to
some extent on what else Windows has to do. Other tasks permitting,
however, the message will be sent immediately. If you check Use Ani-
mation To Confirm Sent Mail using Options/ Environment in the
Custom menu, a post van will cross the screen to show the mail has been
submitted; the post office icon will change while the message is actually
being sent:

Several menu commands also have an effect on compose windows. For
example, Set Font in the View menu changes the font used to display the
message in the compose window. See the “Menus” section of this manual
for more details.

You can close the currently selected compose window by:

clicking on the Windows control box at the top left-hand corner of
the read window to drop down the control menu, and then
selecting Close,

or

double-clicking on the control box.
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Form Windows

A form window is similar to a compose window but instead of using it to
create an individual message, you use it to create and edit a template to be
used as the basis for messages that you have to send repeatedly. For
example, you could have one form for expenses claims and another for
meeting agendas.

You can create and save as many forms as you like.

See Forms in the Message menu for full instructions on opening and
using form windows.
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Signature Windows

You use signature windows to create and edit the signature appearing at
the bottom of messages you send. You can create and save as many
signatures as you like. You can select one of them as your default to be
attached automatically at the end of messages, but you can always select
another one or choose to use no signature for individual messages.

See Signatures in the Message menu for full instructions on opening and
using signature windows.
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The Toolbar

The buttons in the toolbar allow you to carry out commands without
having to select them from a menu. This section gives a brief description
of the action of each tool; more details can be found in the description of
the command in the relevant menu.

Next and Previous
Move to the next or previous message in the currently
selected message list, or the next or previous folder if the
message store window is selected.

If the current selection is the first or last in the list, one of the buttons is
grayed to show you cannot move in that direction. Both buttons are
grayed if, for example, a compose window is selected, so there is no
currently selected message or folder.

These buttons are equivalent to Next and Previous in the View menu.

Read message
Open a read window for the message currently selected in a
message list window.

This button is equivalent to Read in the Message menu.

Reply to message
Open a compose window to reply to the message currently
selected in a message list window or in a selected read window.
The settings you have made using Options/Reply in the
Custom menu determine whether the compose window opens
with the original message included and whether the reply is
addressed just to the sender or to everyone who received copies
of the original.

This button is equivalent to Reply in the Message menu, except that in
the menu version you select who the reply is sent to, and whether or not
to include the original message, in a submenu rather than using the
Options/Reply defaults.
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Compose new message
Open a compose window for a new message.

This button is equivalent to Compose in the Message menu.

Save
Saves the currently selected read message, compose message,
signature or form to a text file.

The setting of Save Header When Saving Text Files in Options/
Environment in the Custom menu determines whether headers are
saved with the body of the message.

This button is equivalent to Save As in the File menu.

Save to folder
Saves the currently selected messages to a folder.

This button is equivalent to Save Message(s) to Folder in the Message
menu.

Cut
Remove the selected text and place it in the Windows clipboard.

This button is equivalent to Cut in the Edit menu.

Copy
Copy the selected text and place it in the Windows clipboard.

This button is equivalent to Copy in the Edit menu.

Paste
Copy the contents of the Windows clipboard to the point in a
document marked by the cursor. The contents of the clipboard
may have originated in Mail-it or another application, but only
text can be pasted into a Mail-it compose window.

If there is a current selection in the document, it will be replaced by the
contents of the clipboard.
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This button is equivalent to Paste in the Edit menu.

Print
Print the current form, signature, read or compose message on
the currently selected printer.

Use Page Setup in the File menu to define a header and footer for the
pages you print out. The setting of Print Header When Printing Files
in Options/Environment in the Custom menu determines whether a
message’s header (as opposed to the page header) is printed with the body
of the message. Use Print Preview in the File menu to check what the
output will look like.

This button is equivalent to Print in the File menu.

Delete
Delete the message currently selected in a read window or a
message list window.

Note that when you delete a message, you also delete its attachments.

This button is equivalent to Delete in the Message menu.

Open message store
The current version of Mail-it only supports a single message
store; future versions will allow you to use several. The open
message store button will allow you to select which message store
to use and to set a default message store.

This button is equivalent to Open Message Store in the Window
menu.

Open selected folder
Opens a message list window for the folder currently selected in
the message store window.

This button is equivalent to Open in the Folders menu.

Version number
Displays the program version number, system information and
copyright notice.
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This button is equivalent to About in the Help menu.

New mail?
Checks whether any new mail has arrived on your mail server,
and if it has, downloads it to your local message store. This
button is equivalent to New Mail? in the Message menu.

The new mail? button changes in appearance when there is any new mail
in the In-Tray folder:
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File Menu

Save As
To save the currently selected signature, form, read or compose
message to a plain text file:

1 Select Save As from the File menu to display a standard Windows
Save As dialog box:

2 Use the Drives and Directories boxes to select a directory to save
the file in.

3 Type a name for the file in the File Name box and press OK.

Check Save Header When Saving Text Files using Options/Envi-
ronment in the Custom menu to decide if the text files should include
header details or just the body of the messages: use Options/Read
Options in the Custom menu to decide how verbose the header details
should be.

To save several read messages in a message list window to a single text file:

1 Select one message in the message list window.
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2 Hold Ctrl as you select other messages, or, if you want to extend
the selection to include a range of messages, hold Shift and select
the message at the other end of the range.

3 Select Save As from the File menu to display a standard Windows
Save As dialog box and proceed as for a single file.

Once a message has been saved as a text file, you can import it into other
applications such as a word-processor, desktop publishing package or
spreadsheet.

Print
To print the currently selected read or compose message, form
or signature:

Select Print from the File menu to display a Print dialog giving
options for your selected printer.

The settings you can make in the Print dialog box will depend on the
printer you have selected: see your Windows and printer documentation
for more information. To change the setup of your printer, or to choose a
different printer, see Print Setup in the File menu.

Note that Print does not print any attachments to messages.

You can decide whether to print the message header with the body of the
message using the Print Header option in Options/Environment in
the Custom menu.

You can also print a header and footer on each page (see Page Setup in
the File menu for more details) and change the font used to print your
message: see Set Printer Font in the View menu.

You will not be able to see the effects of changing the header and footer
or the printer font in the message window, but you can see what the
message will look like using Print Preview.

Print Preview

To see what your read or compose message, form or signature will look
like when it is printed:

Select Print Preview from the File menu to display a window
with your message formatted for printing.
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Press Print to print the document being previewed.

Press Next Page to view the following page in the message.

Press Prev Page to view the preceding page in the message.

Press Two Page to preview two pages side by side at the same
time. The button changes to One Page allowing you to change
back to previewing one page at a time. Two page preview is only
available if the page is not zoomed.

Press Zoom In to view the document at a larger magnification.

Press Zoom Out to view the document at a lower magnification.

Press Close to return to the Mail-it application window.

You can change the font used for printing using Set Printer Font in the
View menu, and the information given in the header and footer using
Page Setup.

Page Setup

To change the information given in the header and footer when you print
a message:

Select Page Setup from the File menu to display the Page Setup
dialog box:

Type into the Header and Footer boxes any text you want to
appear in the header or footer of the message when it is printed.
You can insert codes in the text to print information associated
with the message.
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The codes you can use are:
&Name Prints the sender’s name;
&Date Prints the time and date the message was

submitted;
&CurrTime Prints the time when the message is printed;
&PageNum Prints the page number;
&Subject Prints the subject of the message;
&To Prints the addressee of the message;
&Cc Prints the addresses of people sent copies.

Print Setup

To change the setup of your selected printer or to choose a different
printer:

Select Print Setup from the File menu to display the standard
Windows Print Setup dialog box:

If you want to change to a different printer:

1 Press the Specific Printer radio button.

2 Select the printer you want from the Specific Printer drop-down
list box.

If you want to change the set up of the selected printer, press the Options
button to display a setup dialog box for that printer.

The settings you can make in this dialog will depend on the printer you
have selected: see your Windows and printer documentation for more
information.
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Exit

To close Mail-it:

Select Exit from the File menu.

If you have any unsaved compose windows open, you will be asked if you
want to save them.

When you next start Mail-it, any message list windows you had open
when you exited will be restored.
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Edit Menu

Undo

To reverse the effect of the last change you made to a message:

Select Undo from the Edit menu.

Undo will replace deleted or cut text, or remove added or pasted text,
whichever was the last operation. You cannot undo changes once they
have been saved.

Cut
To remove text from a compose window, form or signature, and
place it on the Windows clipboard:

1 Select the text by placing the cursor at one end and dragging to the
other end.

2 Select Cut from the Edit menu.

Once you have placed text or an object in the Windows clipboard you
can paste it into another Mail-it window or another application document
using Paste.

Note that you cannot Cut text from read windows, but you can Copy it.

Copy
To copy text from a form, signature, read or compose window,
and place it on the Windows clipboard, without removing it
from the original window:
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1 Select the text by placing the cursor at one end and dragging to the
other end.

2 Select Copy from the Edit menu.

Once you have placed text in the Windows clipboard you can paste it into
another Mail-it window or another application document using Paste.

You can copy text from read windows, as Copy leaves the original
unchanged.

Paste
To copy text from the windows clipboard into a compose
window, form or signature:

1 Place the cursor where you want to make the insertion, or if you
want to replace some text, select the text you want to replace.

2 Select Paste from the Edit menu.

You can use Paste to insert text that you have cut or copied from the
same Mail-it window, a different Mail-it window or another application.

Delete

To delete text from a form, signature or compose window:

1 Select the text you want to delete by placing the cursor at one end
and dragging to the other end.

2 Select Delete from the Edit menu.

Find

To find a specific string of text in the body of a message:

1 Place the cursor in the message.

2 Select Find from the Edit menu to display the Find dialog box:
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3 Type the text you want to find in the Find What text box.

4 Check Match Case if you only want to find text with exactly the
same pattern of upper and lower case letters.

5 Select the Up or Down radio button to choose whether to look
for the text earlier or later in the message.

6 Press Find Next to search for the text.

If the text is found, the window will, if necessary, scroll to show the found
text and highlight it.

To find another occurrence of the text in the message without closing the
Find dialog box:

Press Find Next again.

To edit the message once you have found the text:

Press Cancel to close the Find dialog box.

Find Next

To search for text again if you have already searched for it using the Find
command and have closed the Find Next dialog box:

1 Place the cursor in the message.

2 Select Find Next from the Edit menu.

The text will be searched for again in the direction set in the Find dialog
box and with the same setting for Match Case.

You can search for the text in the same message or another message in a
different read or compose window.

Replace

To find a specific string of text in the body of a message and replace it
with a different string of text:

1 Place the cursor in the message.

2 Select Replace from the Edit menu to display the Replace dialog
box:
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3 Type the text you want to find in the Find What text box.

4 Check Match Case if you only want to find text with exactly the
same pattern of upper and lower case letters.

5 Type the text you want to take the place of the found text in the
Replace With text box.

If you want to replace all occurrences of the search text with the replace
text:

Press Replace All to search for all occurrences of the text and
replace them with the replace text.

If you want to choose which occurrences of the text to replace with the
replace text:

Press Find Next to search for the next occurrence of the text.

If the text is found, the window will scroll, if necessary, and the found text
will be highlighted.

If you want to replace this occurrence:

Press Replace.

If you do not want to replace this occurrence, but want to look for further
occurrences:

Press Find Next.

When you have made all the changes you want to make:

Press Cancel to close the Replace dialog box.

Insert from File

To insert text from a file into a message in a compose window, a form or a
signature:
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1 Place the cursor where you want to make the insertion, or if you
want to replace some text, select the text you want to replace.

2 Select Insert from File from the Edit menu to display a standard
Windows Open file dialog box:

3 Use the dialog box to select the file you want to insert.

4 Press OK to insert the selected file into the message.

Note that you can only insert text from a file into the body of a message,
not into the text boxes at the top of the compose window.

Insert Object

This command will be used in future versions of Mail-it to insert objects
into the body of a message.

Edit Object

This command will be used in future versions of Mail-it to edit objects
placed in the body of a message.

Deselect All

To deselect all of the text in the body of the current message:

Select Deselect All from the Edit menu.

Select All

To select all of the text in the body of the current message:

Select Select All from the Edit menu.
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View Menu

Next
To select the next folder, if the message store window is se-
lected, or the next message, if a message list or a read window is
selected:

Select Next in the View menu.

If a read window is selected, Next displays the next message in the
message list in the read window.

Previous
To select the previous folder if the message store window is
selected or the previous message if a message list or a read
window is selected:

Select Previous in the View menu.

If a read window is selected, Previous displays the previous message in
the message list in the read window.

Toolbar

To change between displaying and not displaying the toolbar:

Select Toolbar in the View menu.

When the toolbar is displayed, Toolbar is checked in the View menu.

Status Bar

To change between displaying and not displaying the status bar:

Select Status Bar in the View menu.
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When the status bar is displayed, Status Bar is checked in the View
menu.

Set Tab Stops

To set the position of tab stops in a read or compose window:

1 Select Set Tab Stops in the View menu to display the Set Tab
Stops dialog box:

2 Type in a figure (from 1 through 16) giving the number of spaces
between tab stops.

3 Press OK to close the dialog box.

The figure you give is used to set the number of spaces between tab stops
across the message window. When you press Tab to enter a tab into text
in a compose window, the cursor moves to the next tab stop. Changing
the tab stop setting in a read window will change the alignment of any
tabbed text.

Each window can have its own setting for the tab stop spacing, but the
same spacing is used for all of the text in that window. Changing the tab
stop setting after you have entered some tabs changes the spacing of the
text you have already entered as well as new text.

Note that you should use a fixed width font such as Courier if the vertical
alignment of text in your message is important – for example if you want
your message to show columns of figures, or even if you just want to use
“~” for underlining a heading – since the recipient may not have a mail
system as sophisticated as Mail-it, and may only be able to use a fixed
width font to read the message.

When you send a message from a compose window that has tabs, the tabs
will be replaced with the appropriate number of spaces.
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Set Font

To set the font used in the selected window:

1 Select Set Font in the View menu to display the screen Font
dialog box:

The range of fonts given depends on the type of window selected
when the dialog box is displayed. If a compose, read, form or
signature window is selected, the full set of fonts installed on your
PC is shown; for message list windows and the message store
window only fixed pitch fonts are shown.

2 Select the typeface from the Font drop-down list box.

3 Select the type style from the Font Style drop-down list box.

4 Select the type size from the Size drop-down list box.

5 Press OK to close the dialog box and change the font used in the
selected window.

You can choose a different font independently for each window. The
exact behaviour depends on the setting of Use Standard Font in the In
Headers box in Custom/Options/Environment. If it is not checked,
all the text in message windows is in the new font, but if it is checked,
only the body of messages is in the new font and the headers etc are in a
fixed system font.

The compose, read, form and signature windows have one default font
used when new windows are opened, other windows have another. The
default font is the last font set for that type of window.
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Note that the font is associated with the window, not the message: if you
close a window and open a new window for the same message, the new
window will be displayed in the current default font, not the font associ-
ated with the old window.

When choosing a font, bear in mind that the font is only used in your
display: it is not transmitted with the message. This means that any
formatting that relies on the spacing of text may be lost. If the formatting is
important, for example if you want to line things up in columns, it will be
safer to use a fixed width font such as Courier.

Set Printer Font

To set the printer font used to print the body of a message, signature or
form:

1 Select Set Printer Font in the View menu to display the printer
Font dialog box:

2 Select the typeface from the Font drop-down list box (only
installed printer fonts are shown).

3 Select the type style from the Font Style drop-down list box.

4 Select the type size from the Size drop-down list box.

5 Press OK to close the dialog box and change the font used to print
the selected window.

You can choose a different printer font independently for each window.
Once you have chosen a printer font, this becomes the default used to set
the printer font for new windows, until you select a new font or choose
Mirror Display Font.
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Note that the font is associated with the window, not the message: if you
close a window and open a new window for the same message, the new
window will be printed using the current default font, which may not be
the font associated with the old window.

When you set a new printer font for a window, Set Printer Font
becomes checked in the View menu when that window is selected, and,
since the display font is not mirrored, Mirror Display Font is not
checked.

Mirror Display Font

To use the same font to print a message as you are using to display it:

Select Mirror Display Font in the View menu.

You can choose a different setting for Mirror Display Font independ-
ently for each window. After you have selected Mirror Display Font,
this becomes the default setting for new windows until you select Set
Printer Font.

Note that the Mirror Display Font setting is associated with the win-
dow, not the message: if you close a window that mirrors its display font,
set a printer font for another window, and then open a new window for
the original message, the new window will have the current default Set
Printer Font setting, which will not necessarily mirror the display font.

When you set a window to mirror the display font when it is printed,
Mirror Display Font is checked in the View menu, and since this
overrides any printer font you have selected, Set Printer Font is un-
checked.

Word Wrap

You can decide how messages should be displayed if their line length is
longer than the width of the read or compose window.

If Word Wrap is selected, a new line is started whenever the message
reaches the right-hand side of the window. In this case, all of the message
can be read within the width of the window, so there is no horizontal
scroll bar.
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If Word Wrap is not selected, a new line is only started if there is a
carriage return in the message. This means that some of the message may
go off the right-hand side of the window, so you may need to use the
horizontal scroll bar.

The default word wrap settings for new read and compose windows are
set using Options/Read Options and Options/Compose Options in
the Custom menu. If word wrap is selected for a compose window, you
can also decide whether the line endings should be transmitted as real
“hard” line breaks when the message is sent: see Options/Compose
Options in the Custom menu and the “Compose windows” section
earlier in this manual.

To override the default settings and switch word wrap off or on:

Select Word Wrap in the View menu.

When word wrap is on, Word Wrap is checked in the View menu.

You can select a different setting for word wrap independently for each
window.

Note that the word wrap setting is associated with the window, not the
message: if you close a window and open a new window for the same
message, the new window will be printed using the current default word
wrap setting, not the setting associated with the old window.
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Folders Menu

Open

To open a message window for the folder currently selected in the
message store window:

Select Open in the Folders menu.

or

Select the folder in the message store window and press the open
folder button.

or

Double-click on the folder in the message store window.

Create

To create a new folder in the folder currently selected in the message store
window:

1 Select Create from the Folders menu to display the Create
Folder dialog box:

2 Type in a name for the folder – this can have up to eight alphanu-
meric characters.

3 Press OK.
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Copy

To copy a folder and its contents to another folder:

1 Select the folder you want to copy in the message store window.

2 Select Copy from the Folders menu to display the Copy Folder
dialog box:

The From text box will show the folder selected in the message
store window.

3 In the To box, select the folder you want to copy the From folder
to.

4 Press OK.

The From folder and any messages and folders it contains will be copied
to the To folder.

Note that you can also copy folders by selecting the folder and holding
Ctrl while you drag it into the folder you want to copy to.

Move

To move a folder and its contents to another folder:

1 Select the folder you want to move in the message store window.

2 Select Move from the Folders menu to display the Move Folder
dialog box:
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The From text box will show the folder selected in the message
store window.

3 In the To box, select the folder you want to move the From
folder to.

4 Press OK.

If the folder you want to move to does not already exist, you will be asked
if you want it to be created.

The From folder and any messages and folders it contains will be moved
to the To folder.

Note that you can also move folders by selecting the folder you want to
move and holding Shift down while you drag it to its new position in the
folder tree.

Note that you cannot move the In-tray or Out-tray folders.

Rename folder

To rename a folder:

1 Select the folder you want to rename in the message store window.

2 Select Rename from the Folders menu to display the Rename
Folder dialog box:
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The From text box will show the folder selected in the message
store window.

3 Type the new name for the folder in the To box.

4 Press OK.

Note that you cannot rename the In-tray or Out-tray folders.

Delete

To delete a folder and all its contents:

1 Select the folder you want to delete in the message store window.

2 Select Delete from the Folders menu.

If you have set Confirm on Delete using Options/Environment in the
Custom menu, you will be asked to confirm that you want to delete the
folder and its contents.

Note that you cannot delete the In-tray or Out-tray folders.
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Message Menu

New Message

To compose a new message:

Select New Message in the Message menu to display a new
compose window:

Full instructions for using compose windows are given in the “Compose
windows” section of this manual.
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Forms

If you regularly send a message with the same or similar content or format,
you can create a form to use as a template. The Forms command allows
you to create and manage forms.

To manage template forms:

Select Forms from the Message menu to display the Select a
Form dialog box:

The operations carried out using this dialog box are described in the
following subsections.

New

To create a new form:

1 Press New to open a New Form dialog box:

2 If the messages built using the form will always be sent to the same
person, enter the address in the To text box.
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3 If you want the messages built from the form to carry the same
subject description, enter it in the Subject field.

4 If the messages built using the form will always be copied to the
same people, enter their addresses in the Cc text box.

5 Type into the main text window any text you want to appear in all
of the messages built using this form.

6 Press OK when you have finished designing the form to display
the Enter Filename dialog box:

7 Type a name for the file in the text box: you can use up to eight
alphanumeric characters.

8 Press OK to close the dialog box and save the form in a file with
the name you have given.

You can also save the contents of a form to a text file using Save As in the
File menu.

Edit

To change an existing form:

1 Select the form in the scroll box in the Select a Form dialog box.

2 Press Edit to open a form dialog box containing the form:
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3 Edit the form.

4 Press OK to close the window and save the edited form.

Use

To use an existing form:

1 Select the form in the scroll box in the Select a Form dialog box.

2 Press Use to open a compose window based on the form:

Delete

To delete an existing form:

1 Select the form in the scroll box in the Select a Form dialog box.

2 Press Delete to delete the form.

If you have set Confirm on Delete using Options/Environment in the
Custom menu, you will be asked to confirm that you want to delete the
form.

Signatures

To create and manage signatures to be added to the end of your messages:

Select Signatures from the Messages menu to display the Select
a Signature dialog box:
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The operations carried out using this dialog box are described in the
following subsections.

The default signature is marked * in this dialog box.

You add a signature to a message by selecting it from a drop-down list box
in the compose window: see the “Compose windows” section earlier in
this manual.

New

To create a new signature:

1 Press New to open a New Signature dialog box:

2 Type in the text you want added to the end of your messages. The
text can be any length, but bear in mind that most people dislike
receiving mail with long or elaborate signatures.

3 Press OK when you have completed the signature, to open the
Enter Filename dialog box:
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4 Type a name for the file in the text box: you can use up to eight
alphanumeric characters.

5 Press OK to close the dialog box and save the signature in a file
with the name you have given.

You can also save the contents of a signature to a text file using Save As in
the File menu.

Edit

To edit an existing signature:

1 Select the signature in the scroll box in the Select a Signature
dialog box.

2 Press Edit to open a signature dialog box containing the signature:

3 Edit the signature.

4 Press OK to close the dialog box and save the signature.

Default

To make a signature the default signature added at the end of messages:

1 Select the signature in the scroll box in the Select a Signature
dialog box.

2 Press Default to make the signature the default.

The default signature is marked * in the Select a Signature dialog
box.

Delete

To delete an existing signature:

1 Select the signature in the scroll box in the Select a Signature
dialog box.
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2 Press Delete to delete the signature.

If you have set Confirm on Delete using Options/Environment in the
Custom menu, you will be asked to confirm that you want to delete the
signature.

Open
To read a message:

1 Use the message store window to open the message list window
containing the message (see the “The message store window”
section earlier in this manual for more details).

2 Select the message in the message list window.

3 Select Read in the Message menu to open a read window
containing the selected message (alternatively, press the read button
or double-click on the message in the message list window):

The appearance of the read window is controlled by settings made using
Options/Read Options in the Custom menu.

Full information about how to use read windows is given in the “Read
windows” section earlier in this manual.
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Delete
To delete a message:

1 If the message is not already open in a read window, use the
message store window to open the message list window containing
the message (see the “Message list windows” section earlier in this
manual for more details).

2 Select the message in the message list window, or the read window
if the message is already open.

3 Select Delete in the Message menu.

If you have set Confirm on Delete using Options/Environment in the
Custom menu, you will be asked to confirm that you want to delete the
message.

Note that when you delete a message, you delete its attachments as well.

Forward

To forward a message and its attachments to someone else:

1 Either select the message in a message list or, if it is already open in
a read window, select the read window (see the “Message list
windows” section earlier in this manual for more details).

2 Select Forward in the Message menu to open a compose win-
dow containing the message to be forwarded:
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The appearance of the forwarded message is controlled by settings
made using Options/Forward Options in the Custom menu.
The example shows the result of using the Forwarding Prologue
String, Forwarding Epilogue String, and Forwarding Indent
String used in the Options/Forward Options example later in
this manual.

3 Fill in the To and Cc fields and make any required edits to the
message.

4 Press Send to forward the message.

The window is a standard compose window, so you can use any of the
editing and menu operations that can be applied to messages in a compose
window: see the “Compose windows” section earlier in this manual for
more details.

Reply
To reply to a message:

1 Either select the message in a message list or in a read window if it
is already displayed in one (see the “Message list windows” section
earlier in this manual for more details on selecting messages and
opening read windows).

2 Choose Reply in the Message menu to display the submenu:

Note that if you use the reply button to carry out this command,
you are not presented with this submenu but the default setting is
used instead: see Options/Reply Options in the Custom menu
for setting the default.

3 Select

to Sender if you want the reply sent to the sender only,

to Sender/Include Message if you want the reply sent to the
sender only and you want the reply to include the original
message,
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to All if you want the reply sent to the sender and anyone else
who was on the Cc list of the original,

or

to All/Include Message if you want the reply sent to the
sender and anyone else who was on the Cc list of the original,
and you want the reply to include the original message.

A compose window will open for you to write the reply:

The To and Cc text boxes will be filled according to which
command was selected, the Subject field will be the same as in the
original message, and, if an Include Message command was
selected, the body of the message will contain a copy of the original
message. The appearance of the included message is controlled by
settings made using Options/Reply Options in the Custom
menu. The example shows the result of using the Reply Prologue
String, Reply Epilogue String, and Reply Indent String used
in the Options/Reply Options example later in this manual.

4 Edit the message for your reply. You can also edit the included
original message – generally you will only want to include short
quotations from the original to set your answer in context. The
window is a standard compose window, so you can use any of the
editing and menu operations that can be applied to messages in a
compose window: see the “Compose windows” section earlier in
this manual for more details.
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Save Message(s) to Text File
This command allows you to save a message (or several mes-
sages), or the body of a compose widow, form or signature to a
text file. The command is the same as Save As in the File menu.

Once a message has been saved as a text file, you can import it into other
applications such as a word-processor, desktop publishing package or
spreadsheet.

Save Message(s) to Folder
To save a message (or several messages) to another folder:

1 If the message you want to save is not already open in a read
window, open the message list window containing the message or
messages you want to save (see the “Message list windows” section
earlier in this manual for more details).

2 Select the message in the message list window or open read
window. If you want to copy more than one message, hold Ctrl as
you select each of the messages, or, to select a number of adjacent
messages, select the message at one end of the range and hold Shift
while you select the message at the other end of the range.

3 Select Save Message(s) to Folder in the Message menu to
display the Save To Folder dialog box:

4 Check Close After Filing if you are saving the message from an
open read window and want to close that window once you have
saved it.

5 Check Move Message(s) if you want to delete the messages from
their current folder when they are saved in the new folder.
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6 Select the target folder to copy the messages into.

7 Press OK to copy (or move) the messages into the selected folder.

Note that you can also use drag and drop to move or copy messages
between folders: see the “Mail-it Windows” section earlier in this manual
for more details on managing messages using message list windows.

Send

To send a message:

1 Make sure the compose window containing the message is se-
lected.

2 Select Send in the Message window or press Send in the com-
pose window.

See the “Compose windows” section earlier in this manual and Options/
Compose Options in the Custom menu for information about priority
settings and other options affecting the sending of messages.

It isn’t possible to say exactly when the message will be sent to the mail
server as this is partly the responsibility of Windows and will depend to
some extent on what else Windows has to do. Other tasks permitting,
however, the message will be sent immediately. If you check Use Ani-
mation To Confirm Sent Mail using Options/ Environment in the
Custom menu, a post van will cross the screen to show the mail has been
sent.

When you send a message it is placed temporarily in your Out-Tray folder
until it has actually been sent. Once it has been sent, it is moved to your
Sent folder, or you can specify another folder for it to be moved to using
Custom/Options/Compose Options or by setting Options in the
compose window.

Re-Send

To compose a new message with a group of received messages as attach-
ments:

1 Open the message list window containing the message or messages
to be attached (see the “Mail-it Windows” section earlier in this
manual for more details on selecting and opening message list
windows).
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2 Select the message in the message list window, or, if you want to
copy more than one message, hold Ctrl as you select each of the
messages, or, to select a number of adjacent messages, select the
message at one end of the range and hold Shift while you select the
message at the other end of the range.

3 Select Re-Send in the Message menu to display a new compose
window with the selected messages as attachments:

The messages you are re-sending are attached as message objects,
which will include any attachments the messages had.

4 Fill in the To and Cc fields and make any required edits to the
message.

5 Press Send to re-send the messages (see Send above).

See the “Compose windows” section earlier in this manual and Options/
Compose Options in the Custom menu for information about priority
settings and other options affecting the sending of messages.

Re-Try

Occasionally, a message may not be sent successfully, perhaps because the
mail server temporarily becomes unavailable. Such messages will remain in
the Out-tray. Select Re-Try in the Message menu to send all the
messages in the Out-tray. In fact, you may not need to use this command,
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as Mail-it will automatically re-try any failed messages along with the next
message you send.

Abort Send

It isn’t possible to say exactly when a message will be sent to the mail
server as this is partly the responsibility of Windows and will depend to
some extent on what else Windows has to do. This means that there is a
short interval after you select Send in the Message menu or press the
Send button in a compose window, before the mail is sent to the mail
server. If you change your mind about sending the mail during this time,
you can prevent the message being sent on to the mail server.

To stop mail being sent:

Select Abort Send from the Message menu.

Once mail has been sent to the server, you cannot abort it from within
Mail-it.

New Mail?

Mail-it automatically checks for new mail at regular intervals (see the
“MIME Receive Setup” section of the “Configuring Mail-it” appendix
for details of setting the interval) and if any has arrived, it downloads it to
your local message store. While new mail is being downloaded into the
In-tray of your local message store the Post Office icon changes:

If you check Use Animation On New Mail using Options/ Environ-
ment in the Custom menu, an animated mail van will show when new
mail has arrived. Mail-it shows when there is unread new mail in the
message store. If the Mail-it application is running but minimized, the
icon changes from

  to 

If the Mail-it application window is open, the new mail button in the
toolbar changes from
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 to 

If you want to know if any new mail has arrived on the mail server
without waiting until the system next checks automatically:

Select New Mail from the File menu;

or

Press the new mail button (  or  )

or, if Mail-it is minimized,

Click on the icon to display the control menu and select New
Mail?

It isn’t possible to say exactly how long it will take to check the mail server
and download any messages, since this depends not only on how long the
messages are but also on what other tasks Windows has to perform. Other
tasks permitting, however, the mail server will be interrogated immedi-
ately to see if there is any new mail.
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Custom Menu

The Custom menu allows you to customize your Mail-it system. The
custom settings are saved separately for each user, so several people can use
the same machine but have their own individual customized settings when
they use Mail-it.

Tasks

Tasks allow you to automate actions in Mail-it. You can define a wide
range of tasks, so this feature is described separately, in the next chapter.

Options

To customize the settings used by Mail-it:

Choose Options in the Custom menu to display the submenu:

Each of these options is described separately in the following subsections.

Compose Options

To specify defaults used for new compose windows (you can override the
defaults by pressing the Options button in a compose window: see the
“Compose windows” section earlier in this manual):

1 Choose Options/Compose Options in the Custom menu to
display the Default Compose Options dialog box:
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2 To set the options:

• Check Delivery Receipt if you want a message returned
saying that the message has arrived at its destination.

If you receive a delivery receipt, you can be sure that the
message has been received on the recipient’s host system.
However, not all systems will respond to a request for a
delivery receipt (basically the requirement is that it should be
running UNIX Sendmail), so you cannot assume that a message
has not been received if you do not get a receipt.

• Check Read Receipt if you want a message returned saying
that the message has been read at its destination.

If you receive a read receipt, you can be sure that the recipient
has read the message. However, not all mail systems (or
recipients) will respond to a request for a read receipt, so you
cannot assume that a message has not been read if you do not
get a receipt. Mail-it will respond to a request for a read receipt
by displaying a dialog box when you first read the message
asking if you want to send a read receipt.
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• Check Use Word Wrap to display messages in the compose
window so that if lines are longer than the width of the win-
dow they are split to appear on successive lines. When word
wrap is in force, all of the message will appear in the width of
the compose window, so there is no need for a horizontal scroll
bar. When word wrap is not in force, you can read the end of
lines that have gone beyond the right-hand edge of the window
using the horizontal scroll bar.

• Check Force Hard Returns to replace the “soft” returns put
in by Mail-it to display the message within the width of a
compose window by “hard” returns when the message is
transmitted. With this option unchecked, the word wrap is a
feature of the compose window display only. The message you
send will only have line breaks where you put carriage returns.
If the formatting of your message is important, for example if it
has tables of figures, and you want the receiver of your message
to see exactly what you see in your compose window, either
check Force Hard Returns, or put in carriage returns by
hand.

If you do not check Force Hard Returns, the length of lines
in your message may exceed the line length limit for messages
on the Internet. If this happens, the MIME message transport
will insert “soft” line breaks to prevent lines becoming too
long. Depending on the recipient’s mail system, these may be
removed and the long lines reconstituted, or left in so that the
message appears with lines broken at the line length limit
marked by an “=” character.

If you want to change the word wrap setting for a particular
compose window after it has been opened, use Word Wrap in
the View menu.

Force Hard Returns is only available if Use Word Wrap is
checked.

3 Choose whether to give the message Urgent, Normal, or Non-
Urgent priority. This has no effect on how long it takes for a
message to reach its destination, but on mail systems supporting
priorities, the priority will be shown in the mail listing. In Mail-it,
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priority is shown in a message list window by different colored
icons: Red for high priority; Yellow for normal priority; Gray for
low priority.

4 In the Message Width box, type in the default width (in number
of characters) you want for compose windows. Check Warn On
Resize if you want Mail-it to warn you if you resize the compose
window to display a different number of characters.

5 In the When Replying Add New Addresses box, choose when
to add new email addresses to your address book when replying to
mail: Mail-it can do this Always, or Never, or if you select
Prompt, it will ask you whether you want to add the address.

6 Check Close Compose Window in the When Sending Mail
box if you want the compose window closed automatically after
you have sent the message.

7 Check Automatically Save To Folder if you want a copy of
messages you send automatically saved to a folder. Checking this
option displays the Select Folder dialog box:

From the scroll box, select the folder you want to save messages in
once they are sent.

8 Type into the Bcc text box any addresses you want to send “blind
carbon copies” to. People on this list will be sent a copy of the
message but their addresses will not appear on the message’s Cc list.

9 Type your name and/or mail address into the Reply To text box.

10 If you change your mind and want to use the previous settings for
the options, press Cancel.
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Forward Options

To specify the defaults used when you forward a message:

1 Choose Options/Forward Options in the Custom menu to
display the Forward Options dialog box:

2 Type in any text you want to appear before the forwarded message
in the Forwarding Prologue String text box. It is often useful to
separate off the message you are forwarding from any covering text
you want to include using a string of repeated characters such as *,
^, or _. Alternatively, you could enter some standard covering text.

3 Type in any text you want to appear after the forwarded message in
the Forwarding Epilogue String text box. It is often useful to
separate off the message you are forwarding from your signature, or
other text following the forwarded message, using a string of
repeated characters such as *, v, or _.

4 Type in any characters you want to appear at the beginning of each
line of the forwarded message in the Forwarding Indent String
text box. A common convention is to use “>” as an indent string.
Readers can then identify forwarded text easily.

If you want to put information about the original message in any of these
strings, you can include:

&Name, which will be replaced by the name of the sender of the
original message;

&Date, which will be replaced by the date the original message was
submitted;
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&Subject, which will be replaced by the subject title of the original
message.

When you forward a message using Forward in the Message menu, a
compose window opens with the forwarding prologue string at the top of
the window. This is followed by the forwarded message with the forward-
ing indent string added to the beginning of each line. Finally, the forward-
ing epilogue string is added after the end of the message. You can edit any
of these features in the compose window.

Read Options

To specify defaults used when you open a read window:

1 Choose Options/Read Options in the Custom menu to display
the Read Options dialog box:

2 Press Show as Edit Box if you want brief header information
(From, Subject, To, Cc, Date) displayed in a scrollable box at the
top of read windows. This option takes up less space than Show as
Fields but you may have to scroll to see all the information.

Press Show Whole Header if you want all the header information
displayed in a scrollable box at the top of read windows. The
header information can become very verbose for MIME messages
and you will probably not want to use this option for normal use.

Press Show as Fields if you want brief header information (From,
Subject, To, Cc, Date) displayed in separate boxes at the top of
read windows. This option takes up more space than Show as
Edit Box but more information can be displayed at the same time.

3 Check or uncheck Use Word Wrap in Read Window to decide
how messages should be displayed if their line length is longer than
the width of the read window.
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If it is checked, a new line is started whenever the message reaches
the right-hand side of the window, even if the line doesn’t end
there. In this case, all of the message can be read within the width
of the window, so there is no horizontal scroll bar.

If Use Word Wrap in Read Window is unchecked, a new line is
only started if there is a carriage return in the message. This means
that some of the message may go off the right-hand side of the
window, so you may need to use the horizontal scroll bar to read
some parts of the message.

If you want to change the word wrap setting for a particular
window after it has been opened, use Word Wrap in the View
menu.

Reply Options

To specify defaults used when you reply to a message:

1 Choose Options/Reply Options in the Custom menu to
display the Reply Options dialog box:

2 To set the default used when you use the reply button (if you use
Reply in the Message menu to open a compose window for a
reply, you select these options from a submenu, so the default
setting has no effect):
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• click on Reply to Sender if you want the reply sent to the
sender only;

• click on Reply to Sender/Include Message if you want the
reply sent to the sender only and you want the reply to include
the original message;

• click on Reply to All if you want the reply sent to the sender
and anyone else who was on the Cc list and received a copy of
the original;

• click on Reply to All/Include Message if you want the reply
sent to the sender and anyone else who was on the Cc list and
received a copy of the original, and you want the reply to
include the original message.

The remaining options take effect only if the original message is included
in the reply. Including some of the original text is useful when you want
to identify specific questions or points raised in the original message.

3 Type in any text you want to appear before the included original
message in the Reply Prologue String text box. It is often useful
to separate off quotes from the message you are replying to from
the text you have written using a string of repeated characters such
as *, ̂ , or _. You could also enter some standard covering text.

4 Type in any text you want to appear after the included original
message in the Reply Epilogue String text box. It is often useful
to separate off quotes from the message you are replying to from
your signature, or other text following the quotes, using a string of
repeated characters such as *, v, or _.

5 Type in any characters you want to appear at the beginning of each
line of the included message in the Reply Indent String text box.
A common convention is to use “>” as an indent string. Readers
can then identify forwarded text easily. “<” is often put before
lines written in response to “>” lines. When replies are made to
replies several levels of “>” can build up identifying the order in
which the conversation was conducted.

If you want to put information about the original message in any of these
strings, you can include:
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&Name, which will be replaced by the name of the original
messages sender;

&Date, which will be replaced by the date the original message was
submitted;

&Subject, which will be replaced by the subject title of the original
message.

Environment

To specify how Mail-it responds to actions you perform:

1 Choose Options/Environment in the Custom menu to display
the Environment dialog box:

2 To select options:

• Check Confirm Drag Operations in the During Drag
Operations box if you want a dialog box displayed asking for
confirmation when you drag a folder or message from one
postion to another.

• Click on Move Message (Copy Message) in the Default
Drag Operation box if you want dragging without holding
Shift or Ctrl to move (copy) a message or folder.
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• Check Close at End of List in the When Deleting Mes-
sages box if you want the read window closed when you
delete the last message in a message list rather than display the
previous message.

• Check Confirm on Delete in the When Deleting box if you
want a dialog box displayed asking you for confirmation when a
message, folder, form or signature is deleted.

• Check Save Header in the When Saving Text Files box if
you want the header (brief or full for read windows depending
on your setting in Read Options) saved with the message
when you save it to a text file using, for example, Save As in
the File menu.

• Check On New Mail in the Use Animation box if you want
an animation to inform you when new mail has arrived.

• Check To Confirm Sent Mail in the Use Animation box if
you want an animation to show when you send mail.

• Check Print Header in the When Printing Files box if you
want the header (brief or full for read windows depending on
your setting in Read Options) printed with the message when
you print it using Print in the File menu.

• Check Use Standard Font in the In Header Fields box if
you want to use the Mail-it system font in message headers and
other text and drop-down boxes rather than the font selected
using Set Font in the View menu, which will then be used for
the body of messages only.

• Check or uncheck Use Local Mapping in the Local
Characterset Mapping box to select which character set is
used to display messages in read and compose windows. If it is
checked, standard US-ASCII characters will be mapped to local
country charactersets using ISO 640, so, for example, in
Sweden the character “[“ will be shown as “Ä” and “\” as
“Ö”.
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• Check Save Desktop When Exiting to save the state of the
desktop when you exit so that when you next start Mail-it, the
same windows are opened with the same messages inside them.

Address Book

To add names to the address book or change those already there:

1 Choose Address Book in the Custom menu to display the
Address Book dialog box:

To add a name to the address book:

Press New to display the New Details dialog box:

Type the new details into the Display Name and Email Address
boxes, and press OK.

To change an entry in the address book:
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Select the name of the person you want to change the details for in
the Name box and press Edit (or double-click on the name) to
display the Edit Details dialog box showing the current details:

Change the details in the box and press OK.

To delete an entry from the address book:

Select the name of the person whose address you want to delete
and press Delete.

If you have a large address book and you are not sure about a name:

1 Press Search to display the Search dialog box:

2 Click on User Name if you want to search through the names in
the address book; click on Email Address if you want to search
through the addresses in the address book.

3 Click Anywhere if you want to search for part of a name (or
address) anywhere within each name (or address) in your address
book; click Start if you want to search only the beginning of
names or addresses. For example, if you search for John and select
Anywhere, you will find not only John Smith but also Bill
Johnson; if instead you select Start, you will find only John
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Smith.In the Search For box, type a part of the name or address
that you know is correct.

4 In the Search For box, type a part of the name or address that you
know is correct.

5 Press Search Next to begin searching the address book. If a
matching name is found, it will be highlighted in the Name box in
the Address Book dialog box.

6 If this is the name you are looking for, press OK, otherwise press
Search Next again to look further down the list. Press Cancel to
give up the search.
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Window Menu

Cascade

To resize and arrange the open (non-minimized windows) in overlapping
layers so that their titles bars are visible:

Select Cascade in the Window menu.

Tile

To resize and arrange the open (non-minimized windows) so that they are
side-by-side and not overlapping:

Select Tile in the Window menu.

Arrange Icons

To tidy up the icons representing minimized windows:

Select Arrange Icons in the Window menu.

Open Default Message Store

Future versions of Mail-it will support multiple message stores and this
command will allow you to close the current message store and change to
your default message store.

Open a Message Store

Future versions of Mail-it will support multiple message stores and this
command will allow you to close the current message store and select
another one.
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Windows open in Mail-it

The windows currently open in the Mail-it application window are listed
at the bottom of the Window menu. To select one of these windows:

Click in the window if it is visible on the screen;

or

Select the window’s name from the list at the bottom of the
Window menu.
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Help Menu

Contents

To display a table of contents for the on-line help system:

Select Contents in the Help menu to open the help system at its
main contents page.

How To

For help in carrying out operations using Mail-it:

Select How To in the Help menu to open the help system at a
How To contents page.

Search

To look for help on a specific topic:

Select Search in the Help menu.

About
For information about this version of Mail-it:

Select About in the Help menu.
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Carrying Out Actions Automatically
Tasks allow you to automate a wide range of actions. They make it
easy to carry out actions you need to repeat frequently, or actions that
you may only want to carry out once, but involve a large number of
messages.

The tasks facility is extremely flexible, allowing you to decide:

• when the task should be carried out – for example, when
mail is received or sent, or at a particular time each day.

• which messages the task should be applied to – for example,
those in a particular folder, or earlier than a particular date,
from or to certain people, about certain subjects or
containing particular key words.

• what should be done to the messages – for example, they
could be selected, moved between folders or deleted. You
can even use tasks to launch your own programs.

These are only some of the possibilities; full details are given in the rest
of this chapter.
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Creating a Task
To create a new task:

1 Select Tasks in the Custom menu to display the Task
Management dialog box:

This dialog box is also used to manage the tasks after you have defined
them: full details are given at the end of this chapter.

2 Press New to display the New Task dialog box:

This dialog box is used to define:

• what event should trigger the task

• which messages should be acted on, and

• what action(s) should be performed.
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Defining trigger events

To define when a task should be triggered:

1 Press Select in the On Event box to display the Select the Event
Type dialog box:

2 Select when the task should be triggered. The options are:

New Mail when new mail arrives

Submitting Mail when you submit mail for sending (for
example by pressing the Send button in a
compose window)

Time Period at a particular time or at regular intervals

User Activated when the Run Now button in the Task
Management dialog box is pressed

Add Mail to Folder when mail is added to a folder (see the
next section for selecting the folder).

3 Press OK.

4 If you selected Time Period, the Configure Event dialog box is
displayed:

If you want to trigger the task at regular intervals, click on the
Every radio button and fill in the Minute box to set how often
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you want the task carried out (you can fill in any time up to 10,080
minutes = 1 week).

If you want to trigger the task at a specific time in the day, click on
the At radio button and fill in the required time in the boxes
following it. If you want the task repeated at the same time on a
particular day of the week, every weekday or at the end of the
week, select the appropriate option from the Repeat Every drop-
down list box.

Press OK.

After you have set the event to trigger the task, you are returned to the
New Task dialog box and the selected event is shown in the On Event
box.

If you want to change the event type, press Select in the On Event box
to display the Select the Event Type dialog box again.

If you want to change a selected time period, press the Configure button
(it is ungrayed if you have selected a time period) to display the
Configure Event dialog box again.

Choosing folders

If you choose an Add Mail to Folder, Time Period or User Activated
event, you need to select a folder (or a group of folders). In the first case
the event is only triggered if a message is added to the selected folder. In
the other cases, the task is only applied to messages in the selected folder(s)
that satisfy the match conditions (see the next section).

For User Activated events, you can opt to look for messages satisfying
the match conditions in the Current Folder (that is, the folder that is
selected when you run the task).

To choose to look for messages in the current folder:

Check Current Folder in the Folder box of the New Task
dialog box.

For Time Period and User Activated events, to opt to look for mes-
sages in any folders within the selected folder:

Check Scan Child Folders in the Folder box of the New Task
dialog box.
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To select a folder:

1 Press Select in the Folder box to display the Select Folder dialog
box:

2 Select a folder from the list box.

3 Press OK.

Choosing messages to act on

You select which messages are acted on by a task by setting conditions that
the messages must match.

To set conditions for choosing individual messages:

1 Press Add in the When Matching box of the New Task dialog
box to display the Select a New Match dialog box:

This dialog box allows you to select which match condition to use.
Messages satisfying this match condition will be acted on by the
task.

2 Select a condition and press OK to display the appropriate dialog
box for setting the condition: these are described in the following
sections.

TASKS.PM5 19/06/95, 12:435



Tasks

4-6

When you have set a condition it appears in the When Matching box of
the New Task dialog box.

Press Add again if you want to add further conditions. When you have set
two or more conditions the And Matches and Or Matches radio
buttons are ungrayed.

To choose only those messages matching all of the conditions you have
set:

Click on the And Matches radio button.

To choose all messages matching any of the conditions you have set:

Click on the Or Matches radio button.

You can change a match condition after you have defined it.

To edit a condition:

1 Select the condition in the When Matching box.

2 Press Edit to display the same dialog box you used to set the
condition: these are described in the following sections.

When you edit a match condition, the Remove button in the dialog box
is ungrayed.

To delete a match condition you have already defined:

Press Remove. You will be asked to confirm your decision.

Date

If you choose to set (or edit) a match on Date in the Select a New
Match dialog box, the Date Criteria dialog box is displayed:

To set a date condition:
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1 Choose the type of condition from the Message Date is drop-
down list box. You can choose Equal to, Not Equal to,
Between, Not Between, After, After or Equal to, Before,
Before or Equal to.

If you choose Between or Not Between, the date boxes in the
To box will become ungrayed so that you can select the second
date.

2 Enter the date(s) you want to set for the condition in the From
(and To) box(es) (the To date must be later than the From date).

3 Press OK to return to the New Task dialog box.

Sender, Message Text, Subject

The dialog boxes displayed when you select Sender, Message Text or
Subject allow you to set conditions on the corresponding fields in the
messages. The dialog boxes are almost identical apart from their titles (the
Sender Contains dialog box does not have the radio buttons in the
Match box). Instructions are given here for the Message Text dialog
box only, but apply equally to the others.

Remember that message text can be very much longer than the text in the
sender and subject fields, so a match using message text will take longer to
complete than a match using the sender or subject.

If you choose to set (or edit) a match on Message Text in the Select a
New Match dialog box, the Message Text Contains dialog box is
displayed:

This dialog box allows you to set a condition on the text in messages.
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To set (or edit) a condition on the text:

1 In the edit box at the top of the dialog box, enter the text you
want matched in the message text. The text you enter will be
matched if it appears anywhere in a message’s body text. For
example, entering “sale” will match messages containing the words
“salesroom” and “wholesale” as well as “sale” itself.

2 Press Add to add the text to the list box below the edit box.

3 Repeat steps 1 and 2 for any other text you want matched (the list
box becomes a scroll box if you add more items than can be
displayed at one time).

4 For a match on message text or subject, you can choose how to
combine conditions if you have entered more than one (if you
have entered more than one condition for the sender, the match
will succeed if the sender matches any of the conditions).

Click on the Any One of these Entries radio button if you want
there to be a match if the message text contains any of the text
items you have added.

Click on the All of these Entries radio button if you want there
to be a match only if the message text contains all of the text items
you have added.

5 Check Match Case if you want matches to be made only if the
case of the text in the message text exactly matches the case of the
text in the items you have added. (The Match Case setting applies
to all of the items; you cannot set it separately for each one.)

6 If you change your mind about a particular item, select it in the list
box and press Delete. (If you want to change an item, delete it and
then add the new version.)

7 Press OK.

Recipient

If you choose to set (or edit) a match on Recipient in the Select a New
Match dialog box, the Enter Recipients dialog box is displayed:
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This dialog box allows you to set a condition on the recipients of mes-
sages. You can set separate conditions that must be matched separately in
the To and Cc fields, or a condition that will match an occurrence in
either field.

To set (or edit) a condition on the text:

1 Type the text you want matched in the To and/or Cc fields. If
you don’t mind in which field a match is made, enter the text in
the Any field. If you enter text in both the To and Cc fields, a
message must be matched on both fields for it to be chosen.

The text you enter will be matched if it appears anywhere in the
relevant field’s text. For example, entering “jo” will match
messages sent to “john”, “joy”, and “david jones” as well as “jo”.

2 Check Match Case if you want matches to be made only if the
case of the text in the fields exactly matches the case of the text in
the items you have added. (The Match Case setting applies to all
of the items; you cannot set it separately for each one.)

3 Press OK.

Message Status

If you choose to set (or edit) a match on Message Status in the Select a
New Match dialog box, the Message Status dialog box is displayed:

To select the type of messages to be operated on by tasks:
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1 Check Read Mail to choose incoming messages that have already
been read.

Check Unread Mail to choose incoming messages that have not
been read yet.

Check Sent Mail to choose all messages that you have sent.

You can check any combination of these to choose messages of
more than one type.

2 Press OK.

Defining the action to be taken

Once you have defined when a task should be carried out and which
messages should be acted on, you need to specify what action should be
taken.

To specify the action(s) carried out by a task:

1 Press Add in the Perform Action box of the New Task dialog
box to display the Select a New Action dialog box:

2 Select the action required and press OK.

If you have chosen Select, you will be returned immediately to
the New Task dialog box as there is no need to specify anything
else about the action. If you have chosen one of the other actions,
an appropriate dialog box is displayed to define how the action is
carried out: these dialog boxes are described in the following
sections.

When you have defined an action it is listed in the Perform Action box
of the New Task dialog box.

Press Add again if you want to add further actions. Actions are carried out
in the order in which you add them. For example, if you want to forward
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the chosen messages and then delete them, you must add the forward
action first, or there will be no messages left to forward.

To change an action after you have defined it:

1 Select the action in the Perform Action box.

2 Press Edit to display the same dialog box you used to define the
action: these are described in the following sections. Since the only
change you can make to a Select action is to remove it, pressing
Edit displays a dialog box asking you to confirm that you want to
remove it.

The dialog boxes for other actions all have a Remove button, which is
grayed when you originally set the action, but is ungrayed when you edit
it.

To delete an action you have already defined:

Press Remove. Again, you will be asked to confirm your decision.

Forward to

If you choose the Forward to action, the Forward to dialog box is
displayed to allow you to specify where the messages should be forwarded:

1 Fill in the addresses of the people you want the messages forwarded
to in the To box and those that you want sent copies in the Cc
box. Alternatively, press Address to display the Address Book
dialog box to choose the addresses from the address book.

2 If you want any text added to the forwarded messages:
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Click on From File to show that you want the text from a file
appended, and either enter the name (and path) of the file in
the text box, or press Browse to display a standard dialog box
for selecting the file.

or

Click on This Text and press Edit to display the Text to
Append dialog box:

Enter the text required and press OK.

3 Click on a radio button in the Priority box to choose a priority
for the forwarded messages. Choose As Original if you want the
forwarded messages to have the same priority as the originals.

4 Press OK.

Delete

If you choose the Delete action, the Confirm Delete dialog box is
displayed:

Check Confirm to be asked for confirmation before the task
deletes the messages.

TASKS.PM5 19/06/95, 12:4312



Tasks

4-13

Save to Text File

If you choose the Save to Text File action, the Save to Text File dialog
box is displayed:

1 Enter the filename (and path) of the file in which you want to store
the message, or press Browse to display a standard dialog box for
selecting the file.

2 Check Append to Existing File if you want the new messages
added to an existing file with the given filename; leave it
unchecked if you want the new messages stored in a new file with
the given filename, overwriting any existing file with the same
name.

3 Press OK.

Save to Folder

If you choose the Save to Folder action, the Specify Folder dialog box
is displayed:

1 Press Select to display the Select Folder dialog box:
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2 Select the required folder from the list box.

3 Press OK to return to the Specify Folder dialog box.

4 Check Move Message(s) if you want the original messages
deleted when the messages are saved to the selected folder; leave it
unchecked if you want a copy of the messages saved to the selected
folder.

Call DLL

You can use a task to apply functions in your own or third party DLLs to
messages by choosing the Call DLL action. When you do this, the
Specify DLL dialog box is displayed:

1 Enter the filename (and path) of the DLL you want to call, or press
Browse to display a standard dialog box for selecting the file.

2 Enter the name of the function that you want to call within the
DLL.

3 Check Pass message handle to function if you want the
function to be given the message as an argument.
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Call Executable

You can use a task to call your own or a third party program by choosing
the Call Executable action. When you do this, the Specify Executable
dialog box is displayed:

1 Enter the filename (and path) of the program you want to call, or
press Browse to display a standard dialog box for selecting the file.

2 Enter the actual parameters that you want supplied to the program
when it is called.

3 Check Call for every matching message if you want the
program run for each message selected by the task; leave it
unchecked if you want it to run only once no matter how many
messages are matched, provided at least one is.

As a simple example of how you might use this feature, you could write a
simple Basic program to play a tune or open a window to tell you when
new mail arrives. You can even do the latter without writing a program
by using notepad.exe as the File Name and the name (and path) of a file
with a notification message to be displayed as the Parameters.

Stop

This action is designed for use when you prioritize tasks (see the later
section of this chapter). The Stop action, which you should make the last
action in the task, ensures that any message it processes is not processed by
any lower priority tasks.
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Checking the task definition and saving it
Once you have defined a task you can see a summary of what it does by
pressing Summary >> in the New Task dialog box (in fact, you can
have the Summary box open while you are defining the task):

Press << Summary to close the summary box.

Once you are satisfied that the task is defined correctly you must save it.

To save the task:

1 Press OK in the New Task dialog box to display the Save Task
dialog box:

2 Enter a brief description of the task in the Description box. This
will appear next to the filename in the Task Management dialog
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box, to help you identify the task and what it does without having
to look at the definition.

3 Enter a filename (without an extension) for the task. This must be
a legal DOS filename.

4 Press OK to return to the Task Management dialog box.

This completes the process of defining a task.
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Managing Tasks
The previous sections have shown you how to create a task using the
Task Management dialog box. Once you have defined one or more
tasks they are listed in the Available Tasks box:

The light bulb next to the task is lit when the task is active: see later for
activating and deactivating tasks.

The symbol next to the task shows what event will trigger the task:

when mail is sent

when new mail arrives

at a particular time or at a regular interval

when you press the Run Now button

when mail is added to a folder.

As well as creating tasks, the Task Management dialog box allows you
to change, delete and manage tasks in a number of other ways.

Prioritizing tasks

Tasks are executed in the order they are displayed in the Task Manage-
ment dialog box. To move a task in the sequence, drag it to its new
position, which is indicated by a black arrow as you drag. Release the
mouse button when the task is in the position you want.
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If you have more tasks than can be displayed at one time in the Task
Management dialog box, you can scroll the box by dragging beyond the
top or bottom of the box. Doing this does not change the position of any
tasks.

Note that when you change the order of tasks, the whole task list must be
re-written, and this can take some time.

Editing a task

To change a task definition:

1 Select the task in the Available Tasks list.

2 Press Edit to display the Edit Task dialog box. Apart from the
title, this is identical to the New Task dialog box and is used in
exactly the same way – see the previous sections.

Deleting a task

To delete a task definition:

1 Select the task in the Available Tasks list.

2 Press Delete. You will be asked to confirm that you want to delete
the task.

Task status

Press Status in the Task Management dialog box to display a log of task
actions performed in the current Mail-it session. The list is indented to
group tasks within events, and actions within tasks.

Active and inactive tasks

Tasks can be either active or inactive. An active task is triggered when the
event defined for it occurs; inactive tasks, with the exception of User
Activated tasks, are not triggered even if the trigger event occurs. When
a task is inactive its light bulb in the Available Tasks list is unlit and the
task appears grayed. If you select an inactive task, the Deactivate button
changes to Activate.

To make an inactive (active) task active (inactive):

1 Select the task in the Available Tasks list.
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2 Press Activate (Deactivate).

Running a task with a User Activated event

To run a task with a User Activated event:

1 Select the task in the Available Tasks list.

2 Press the Run Now button.

The task will be run even if the task is inactive.
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Appendix A: Configuring Mail-it
When you install Mail-it, an extra item is added to the Windows Control
Panel. You use this to configure the messaging subsystem used by Mail-it
to send messages. You will normally only have to do this when you first
install Mail-it, when there is a new user, or if there is a change to the
network environment.

Unless you are a systems or network manager or are setting up the mail
system for yourself, you will probably never need to use the commands
described in this section. If you are going to use them, you will need to
understand how your network and mail system are configured and what
protocols are available on the mail server.

NOTE: If you are using Mail-it as part of the PIPEX Dial set of
programs, the only settings you can change are those described in the
“Send setup” section (pages A-6–A-9), steps 7, 8 and 10 of the
“Receive setup” section (pages A-11–A-12), step 3 of the “Message
Store Configuration” section (page A-13) and the “Local Message
Store MIME Configuration” section (pages A-13–A14).

If you are the systems administrator of a local network (that is, not a
PIPEX Dial user), you must enter configuration details for each new user.
You may also want to create a user called “Default”, which will be used
when simple MAPI applications send mail when Mail-it is not already
running. If there is no “Default” user, the sender of the mail will be
prompted to log on to the messaging subsystem.

To configure the messaging subsystem:

1 Double-click on the Windows Program Manager Control Panel
icon. This is in Program Manager’s Main group by default. When
the Control Panel opens, you will see the Mail-it Setup icon.

2 Double-click on the icon to display the Mail-It Messaging
Subsystem logon dialog box:
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In order to maintain the security of your mail system, the configuration of
the messaging subsystem is protected by a password.

To log on to the messaging subsystem as an existing user:

Enter your logon name and password to display the Configure
Mail-it Messaging Subsystem dialog box: this is described in
detail later in this section.

If this is the first time you have used Mail-it, you will need to log on as a
new user and set your password.

To log on to the messaging subsystem as a new user:

1 Enter the name you want to use as your identifier. You will be
asked if you want to create a new user with the name you entered:

2 Press Yes to display the Add a New User dialog box:

3 Enter a path for the directory you want to use to keep your
signature files, forms and user configuration information.
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4 Press OK to display the Configure Mail-it Messaging Subsys-
tem dialog box:

The Configure Mail-it Messaging Subsystem dialog box is the entry
point to a number of different configuration options, covering the
Address Book, Transport, and Message Store. These are described in
detail separately in the following sections.

Future versions of Mail-it will support multiple address books, transports
and message stores, which you will be able to add using the Add button,
and remove using the Remove buttons. These buttons have no function
in the current version of Mail-it.

The Password box allows you to change your password for the Mail-it
messaging subsystem. To change your password:

1 Delete your current password from the Password box – it will
appear as a row of *s for security.

2 Type your new password into the Password box – it will also
appear as a row of *s for security.

3 When you press OK to close the dialog box, you will be asked to
type in your password again to check that you typed it correctly.
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Address Book Configuration
Pressing Setup in the Address Book box of the Configure Mail-it
Messaging Subsystem dialog box displays the Address Book Provider
Setup dialog box:

Type in the path for the directory you want to hold your address
book.
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Transport Configuration
The Mail-it mail transport is the only transport available for the current
release of Mail-it, so pressing Setup in the Transport box of the
Configure Mail-it Messaging Subsystem dialog box displays the Mail-
it Transport Setup dialog box:

1 Enter the name you want to be known by in the Your Name
box.

2 Enter your E-mail address in the Mail Address box. This is the
address that will be placed in the “from” field of messages you
send.

3 Enter the full domain name of your PC in the PC Name box.

Currently, Mail-it only supports Windows Sockets for the network
connection and SMTP for sending, so the two drop-down list boxes at the
top of the Network Protocol Details box provide no alternatives. How-
ever, both Pop-2 and Pop-3 are supported for receiving.

To change the protocol used for receiving mail:

Select the required protocol from the Receive drop-down list
box.

The setup dialog boxes for each of these protocols is described in detail
later in this section.

Network setup

To set up the network:
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1 Press Net Setup in the Mail-it Transport Setup dialog box to
display the Network Transport Setup dialog box:

The current network transport settings are shown in the top of
the dialog box.

2 In the Network Traffic Trace Options box, choose whether
network traffic information should be displayed on the screen or
logged to a file (leave both boxes unchecked if you don't want to
trace network traffic). If you check Log To File, type a file name
for the log into the box.

3 Check the Report Failed Connections box if you want network
errors to be reported. You may prefer to leave this box unchecked
if your computer is not permanently connected to the mail server.

Send setup

To set up SMTP for sending mail:

1 Press Send Setup in the Mail-it Transport Setup dialog box to
display the Mail-it SMTP Setup dialog box:

APENDIX.PM5 19/06/95, 12:166



Mail-it Appendices

A-7

2 Enter the name of your mail server in the Host Name box.

3 Check the Warning box if you want Mail-it to give a warning and
the opportunity to cancel when you send a message larger than the
limit you type into the Kbytes box.

4 Press Setup MIME to set up how messages are sent using MIME.
This displays the Mail-it MIME Send Setup dialog box:

You use this dialog box to configure the conversion of messages from
MAPI to MIME format. It is divided into a number of sections, which are
described separately below.

Conversion configuration files

When you send a message it has to be converted from the MAPI format to
the MIME format. Mail-it comes with default conversions but if you are
an advanced user you can also write your own conversion configuration
files (see Appendix B). Mail-it allows you to define two separate configu-
ration files: a “user” configuration file and a “system” configuration file.
When you send a message the Mail-it messaging system first searches your
user configuration file, then your system configuration file, and finally the
Mail-it defaults, until it finds a conversion for the type of message being
sent.

To set the conversion files to be used when sending mail:
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Enter the full path and filenames of your conversion files in the
User and System boxes. If you just want to use the Mail-it default
conversions, leave these boxes blank.

Note that you can set separate (or the same) conversion configuration files
for receiving, sending and storing messages in the message store: see the
“Receive setup” and “Message store configuration” sections in this
appendix.

Type handling

Text can be represented in a number of different ways depending on the
character set you are using. The Type Handling box allows you to
specify how text should be encoded in the MIME message. The specified
7 bit encoding will be used for US-ASCII; the 8 bit encoding will be used
for all other text. The allowed encodings are:

• 7bit

• 8bit

• quoted-printable

• base64

• binary

• any user encoding defined within the conversion configuration
file.

To specify how 7 and 8 bit text should be encoded:

Select the encoding from the Encode 7 bit text and Encode 8 bit
text drop-down list boxes, or enter the name of your own encod-
ing.

The defaults are quoted-printable for 8 bit and 7bit binary for 7 bit.

To specify what character set should be used in the MIME message for
any text that is not US-ASCII:

Select or enter the name of the character set in the Secondary
charset drop-down list box.

Mail-it recognizes US-ASCII and ISO-8859-1 to ISO-8859-9, which are
the character sets recommended in the MIME defining document
(RFC1521).
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MIME mail systems can cope with messages containing lines longer than
76 characters, but if you are sending mail to sites which do not have a
MIME-capable mail system, you will need to restrict the length of lines so
that the message can be read.

To encode messages with long lines so that they can be read by non-
MIME mail systems:

Check the Encode long lines with more than box and enter the
upper limit for the length of line in the characters box. The
allowed values are 76 to 1024.

This ensures that the quoted printable encoding will be used for long lines.

The default setting is checked with a line length of 76 characters.

Message constraints

In future versions of Mail-it you will be able to use the Message Con-
straints box to specify an upper limit for message size, so that messages
larger than this size are split into several smaller messages.

Conversion warnings

To disable warnings caused by problems when the Mail-it messaging
subsystem converts your message from MAPI to MIME format:

Check the box for the warning you want to disable in the Disable
Warnings box.

Receive setup

To set up Pop-2 or Pop-3 for receiving mail:

1 Select Pop-2 or Pop-3 in the Receive box in the Mail-it Trans-
port Setup dialog box, depending on which you want to use.

2 Press Recv Setup in the Mail-it Transport Setup dialog box to
display the Mail-it Pop-2 Setup or Mail-it Pop-3 Setup dialog
box:
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The only difference between the two dialog boxes is that the Pop-
2 dialog box does not have a Password Protocol box, so the
instructions given here, apart from those concerned with the
Password Protocol box, apply to Pop-2 as well as to Pop-3.

3 Type the name of your mail server in the Host Name box.

4 Type the name you use to log in to the mail server in the Login
name box.

5 Type your password to the mail server in the Password box.

6 If you are using Pop-3, click on the password protocol you want to
use in the Password Protocol box. The choice of password
protocol affects the security of your password. Choose:

Normal if the connection to the mail server is secure or you
are not concerned about the security of your password. With
this option your password will be sent unencoded to the mail
server over the network, so it is potentially insecure, since it
could be understood if it were intercepted en route.

RPOP if you want to use the UNIX rsh protocol to log in to
the mail host. You will not need to send a password, but you
will only be able to log in from a specified PC.

APOP if you want to send an encrypted message digest to
provide login validation.

7 Type a number into the Check Mail every box in the Receive
Options box to specify how often you want Mail-it to check the
mail server to see if new mail has arrived.
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8 Check Address Book Auto Update if you want Mail-it to add
the new address to your address book when you receive mail from
someone for the first time.

9 Check Leave Mail on Host in the Receive Options box if you
do not want mail automatically downloaded to your PC.

Note that with POP-2, selecting this option will cause all your mail
to be downloaded to your PC each time you check for new mail.

10 Press Setup MIME to set up how MIME messages are received by
displaying the Mail-it MIME Receive Setup dialog box:

You use this dialog box to configure the conversion of messages from
MIME to MAPI format. It is divided into a number of sections, which are
described separately below.

Conversion configuration files

When you receive a MIME message it has to be converted to the MAPI
format for you to read it. Mail-it comes with default conversions but if
you are an advanced user you can also write your own conversion con-
figuration files (see Appendix B). Mail-it allows you to define two separate
configuration files: a “user” configuration file and a “system” configura-
tion file. When you receive a message the Mail-it messaging system first
searches your user configuration file, then your system configuration file,
and finally the Mail-it defaults until it finds a conversion for the type of
message being received.

To set the conversion files to be used when receiving mail:
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Enter the full path and filenames of your conversion files in the
User and System boxes. If you just want to use the Mail-it default
conversions, leave these boxes blank.

Note that you can set separate (or the same) conversion configuration files
for receiving, sending and storing messages in the message store: see the
“Send setup” and “Message store configuration” sections in this appendix.

Multipart/alternative body MIME messages

MIME messages can hold alternative forms of the same data in a message
so that the receiving system can choose the format that suits it best. When
you receive such a message, the Mail-it messaging subsystem has to select
which version to use. You can specify one of the options in the Type
Handling box.

To select how alternative parts are chosen from multipart/alternative body
MIME messages:

Click on Configuration table order in the Type Handling box
to use the order defined in the conversion configuration file. The
order is defined by the order in which conversions occur in the
file: the earlier they occur, the higher their priority.

Click on MIME message order in the Type Handling box to
use the order of parts in the message itself as the basis for deciding
which part to use. The recommended order of parts in a MIME
message goes from simplest (for example plain text) to most
complex (for example formatted text in a word-processed file).
Choosing MIME message order means the Mail-it messaging
subsystem will select the most complex part with a defined conver-
sion (the part occurring latest for which the configuration file has a
conversion defined).

MIME message order is the default.

Conversion warnings

To disable warnings caused by problems when the Mail-it messaging
subsystem converts your message from MIME to MAPI format:

Check the Non conformity box in the Disable Warnings box
to disable warnings.
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Message Store Configuration
To set the location of your local message store and its configuration for
handling MIME messages:

1 Press Setup in the Message Store box in the Configure Mail-it
Messaging Subsystem dialog box to display the Mail-it Local
Message Store Setup dialog box:

2 Type in the path for the directory you want to hold your local
message store.

3 Check Address Book Auto Update if you want Mail-it to add
addresses of new recipients to your address book when you read
the message.

4 Press Setup MIME to set up how MIME messages are handled in
the message store: see the instructions immediately following these.

5 Press OK to record the path to your local message store and its
MIME setup. You will be asked to confirm that you want to create
the new message store:

Pressing Setup  MIME in the Mail-it Local Message Store Setup
dialog box displays the Mail-it Local Message Store MIME Configu-
ration dialog box:
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You use this dialog box to configure the way MIME messages are handled
in the message store. It is divided into a number of sections, which are
described separately below.

Conversion configuration files

When messages are received by Mail-it they are saved in the message store
without any conversions being made. This means that they must be
converted to MAPI format when they are read. You can control how this
is done using the Conversion Configuration Files box.

Mail-it comes with default conversions but if you are an advanced user
you can also write your own conversion configuration files (see Appendix
B). Mail-it allows you to define two separate configuration files: a “user”
configuration file and a “system” configuration file. When you open a
read window to read a message the Mail-it messaging subsystem first
searches your user configuration file, then your system configuration file,
and finally the Mail-it defaults until it finds a conversion for the type of
message being read.

To set the conversion files to be used when reading mail:

Enter the full path and filenames of your conversion files in the
User and System boxes. If you just want to use the Mail-it default
conversions, leave these boxes blank.

Note that you can set separate (or the same) conversion configuration files
for receiving, sending and handling messages in the message store: see the
“Send setup” and “Receive setup” sections in this appendix.
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Type handling

To specify what character set should be used when sending a MIME
message with text that is not US-ASCII:

Select or enter the name of the character set in the Secondary
Charset drop-down list box. Mail-it recognizes US-ASCII and
ISO-8859-1 to ISO-8859-9, which are the character sets recom-
mended in the MIME defining document (RFC1521).

MIME messages can hold alternative forms of the same data in a message
so that the receiving system can choose the format that suits it best. When
you receive such a message, the Mail-it messaging subsystem has to select
which version to use. You can specify one of the options in the Type
Handling box.

To select how alternative parts are chosen from multipart/alternative body
MIME messages:

Click on Configuration table order in the Type Handling box
to use the order defined in the conversion configuration file. The
order is defined by the order in which conversions occur in the
file: the earlier they occur, the higher priority they have.

Click on MIME message order in the Type Handling box to
use the order of parts in the message itself as the basis for deciding
which part to use. The recommended order of parts in a MIME
message goes from simplest (for example plain text) to most
complex (for example formatted text in a word-processed file).
Choosing MIME message order means the Mail-it messaging
subsystem will select the most complex part with a defined conver-
sion (the part with a conversion defined in the configuration file
that occurs latest in the message).

MIME message order is the default.

Conversion warnings

To disable warnings caused by problems when the Mail-it messaging
subsystem stores your MIME messages:

Check the box for the warning you want to disable in the Disable
Warnings box.
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Appendix B: Conversion Configuration Files
This appendix defines the syntax used for conversion configuration files.

Mail-it allows you to specify conversion configuration files defining how
messages should be converted between MAPI and MIME. You can specify
two files: a User file and a System file, the only difference between the two
being the priority given to the conversions they contain.

When a conversion is to be made, the messaging subsystem searches for
conversions that match the source type. Some of the conversions may
contain a test, which is then applied to the source to check if the conver-
sion can be applied. If there is more than one conversion matching the
source type and passing any tests, the target type, if it is known, is
matched.

If there is more than one conversion with matching sources and targets,
and with tests that succeed, the choice of conversion is decided by their
priorities. Conversions in the User file have higher priority than any
defined for the same types in the System file, which in turn have higher
priority than the default conversions. Within a file, conversions appearing
earlier in the file have higher priority than any occurring for the same
types later in the file.

As well as specifying how a MAPI type is to be converted to a MIME type,
and vice versa, the conversion configuration file can specify the encoding
to be used.

General structure of conversion configuration files

Configuration files are plain text files consisting of a series of configuration
blocks separated by blank lines. Configuration blocks themselves must not
contain any blank lines. Lines beginning with # are ignored, so they can
be used for documenting the file with comments.

A configuration block can be one of three types, distinguished by begin-
ning with a line consisting of

[INTERNAL CONV]

or

[EXTERNAL CONV]
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or

[ENCODING]

The difference between external and internal conversion configuration
blocks is that external conversion configuration blocks cannot use any of
the built-in conversions, while internal conversion configuration blocks
can only use the built-in conversions. Both types of conversion blocks are
used to define the conversion of a MAPI to a MIME type and/or vice
versa. Encoding blocks are used to define encodings.

External conversion configuration blocks

Following the  line, there are two fields (lines)
defining the MIME and MAPI types between which the conversion is
defined. These lines have the form

<mime type>

and

<mapi type>

Where <mime type> is the name of a MIME type (such as
) and <mapi type> is the DOS file extension of the MAPI attach-

ment (such as ). The name of the MIME type can include a
wildcard for subtypes, so, for example,  will match any MIME
type whose primary type is .

Following these lines, there must be a field (line) defining a MIME to
MAPI or a MAPI to MIME conversion, or fields defining both. These
fields have the form

<definition>

<definition>

where <definition> is a comma-separated list of one or more keyword–
value pairs:

<keyword1>: <value1>, <keyword2>: <value2> ,......

Because commas are used to separate the keyword–value pairs, they cannot
be included in values. The keyword in each pair specifies a particular
aspect of the conversion and the value defines how that aspect should be
handled.
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The keywords and possible values are given below.

Keyword Values

The value gives the encoding to be used to convert from MAPI
to MIME.

Possible values:

user conversions defined in a conversion
configuration file (see later in this appendix).

Default

Example

(This is not supported in the current version of Mail-it.) The
value indicates whether the MAPI type should be sent with the
MIME type in a multipart/alternative MIME part.

Possible values:

Default  (ie send as MIME only)

Example

The value indicates whether the MAPI type is binary data or
not. If it is not binary, it is assumed to be textual and any form of
linefeed (\r\n, \n or \r) is converted to a \r\n sequence.

Possible values:

Default  (ie textual)

Example

The value is a template for the command line sequence to
convert the MAPI type to the MIME type. The following
parameters can be used in this command line template:

this will be replaced by the input file for the
conversion (the MAPI part to be converted).

this will be replaced by the output file for the
conversion (the MIME part to be sent).

this will be replaced by the type of the MAPI
part to be converted (the contents of the
MAPI field in the conversion block).

this will be replaced by the type of the MIME
part to be sent (the contents of the MIME
field in the conversion block).

Example
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The  conversion, which does no conversion, can also be
used.

This is the same as a conversion, except that the conversion
program provides additional parameters to be placed (in MIME
format) at the beginning of the part.

Keyword Values

This value is a ; separated list of <parameter> = <value> items
that the MIME part must have if the conversion is to be carried
out. If the values have to contain a  or  the whole value should
be placed in quotes

Example

This is essentially the same as for  with the
addition of a  specific parameter:

which will be replaced by the description, if any, given to the
MIME part in the message.

Internal conversion configuration blocks

Following the  line, there must be a field (line)
defining either the MIME or MAPI type (not both) to be converted. This
line has the form

  <mime type>

or

  <mapi type>

Where <mime type> is the complete name of a mime type (such as
) and <mapi type> is the DOS file extension of the MAPI

attachment (such as ).

Following this lines, there must be a field (line) defining the MIME to
MAPI conversion if the block is for a MIME type, or the MAPI to MIME
conversion, if the block is for a MAPI type. These fields have the form

<definition>

<definition>
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These fields have the same structure as for external conversions. However,
a conversion value can only be one of the built-in conversions, which,
with the exception of , cannot be used with external conversions.

Built-in conversions
MIME to MAPI

Converts a MIME part to a MAPI .TXT type. If it is the first part in the
message, and not too large, it will be the message text of the MAPI
message, otherwise it will be made an attachment.

Converts what is assumed to be a MIME compliant message to a MAPI
message.

See 

See 

These convert what is assumed to be a multipart/mixed, multipart/parallel
or multipart/digest MIME part to attachments of a MAPI message. If the
multipart is itself a part of another multipart message, a new MAPI
message is created and the parts attached to it, otherwise the parts are
attached to the top-level MAPI message.

Chooses the preferred alternative from what is assumed to be a multipart/
alternative MIME message (see the “Receive setup” and “Message store
setup” sections of Appendix A for information on how to set the way
preferences are decided).

Converts an arbitrary MIME type to a MAPI attachment, using informa-
tion contained in the MIME part to determine the type, or failing this, sets
it to be a generic binary data type. This is the default for any unrecognized
type.

Does no conversion.

MAPI to MIME

Converts a MAPI text part (message or attachment) to a MIME text/plain
type. US-ASCII is used if possible, otherwise the user’s secondary
character set is used. The secondary character set is specified in the Mail-it
Mime Send Setup and Mail-it Local Message Store MIME Configu-
ration dialog boxes (see the “Send setup” and “Message store setup”
sections in Appendix A for more information). This dialog box also allows
you to force lines longer than a certain length to be broken up into shorter
lines so they can be read more easily on a non-text-wrapping terminal.

Converts an arbitrary MAPI type (not a MAPI object) and to an applica-
tion/octet-stream MIME message part.

Does no conversion.

BPENDIX.PM5 19/06/95, 12:185



Mail-it Appendices

B-6

Encoding blocks

Following the  line, there must be a field (line) defining the
name of the encoding to be used for MIME messages. This line has the
form

: <encoding name>

Following this field (line), there must be a field (line) defining a MAPI to
MIME encoding or a MIME to MAPI decoding, or fields defining both.
These fields have the form

<coding method>

or

<coding method>

Where <coding method> is a built-in coding method or a command line
template for the coding (you can use the  and 
parameters for use with the command line template, as with conversions).

Examples

Built-in codings
Encodes or decodes data to or from base64 (see the MIME definition
document RFC1521 for details of the encoding).

Encodes or decodes data to or from quoted-printable (see the MIME
definition document RFC1521 for details of the encoding).

Does no encoding or decoding.

Default conversions

The following default conversions are defined in the Mail-it messaging
subsystem. These are defined internally and do not follow all the rules
required of conversions defined in conversion files. However, for conven-
ience they are given here using a similar syntax, which introduces a

 block. This combines the properties of internal and external
conversions in that both source and target types are given, as in an external
conversion, and built-in conversions can be used, as in an internal conver-
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sion. The syntax is also extended to include the MAPI type *MSG, a
generic MAPI message. Note that these extensions to the syntax are
simply to allow the default conversions to be described simply and con-
cisely; they will not be recognized if you use them in a conversion file.
The definitions also use a number of built-in conversions that are used by
the default conversions, but cannot be used in a user-defined internal
conversion. These conversions are all from MAPI to MIME:

Converts a MAPI message and its attachments to a MIME message.

Converts a MAPI message and its attachments to a multipart/mixed
MIME part.

Converts a MAPI message and its attachments to a multipart/parallel
MIME part.

Converts a MAPI message, which should have no message text, and its
attachments, which should all be MAPI messages, to a multipart/digest
MIME part.

With this extended syntax and these additional built-in conversions, the
default conversions can be defined as follows:
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20, 3-10, 3-46, 3-58

P
page number

printing  3-30
Page Setup  2-27–2-29, 3-29–3-30
password  1-6, 2-2, 3-4, A-3

configuration  1-7
Pop-3 protocol  A-9–A-10

Paste  3-25, 3-33
Pop-2/Pop-3  A-5

setting up  A-9–A-10
Previous  2-10, 3-37
Print Preview  3-28–3-29
Print Setup  2-28, 3-30
printer

selecting  3-30
printing  3-25, 3-28
priority of messages  3-12, 3-65
Privacy Enhanced Mail  1-13
prologue string  2-15, 3-66, 3-

69–3-70
protocols  1-14, A-5

R
Re-Send  3-58–3-59
re-sending  2-18–2-19
read options  3-67–3-68
read receipt  3-63
read window  3-14–3-16

closing  3-16
opening  3-14

receive setup  A-9–A-12
replacing text in message  3-34–3-

35
Reply  3-55–3-57
reply

sending  2-17–2-18

reply options  2-15–2-16, 3-68–3-
70

S
Save Message(s) to Folder  2-

23, 3-57–3-58
Save Message(s) to Text File  3-57
saving messages  2-21, 3-24
send setup  A-6–A-8
sending messages  2-5, 2-40–2-

41, 3-58
from MAPI-aware appplications

3-2–3-7
to more than one person  3-17

Sent folder  2-8–2-9, 2-20, 3-10
Set Font  2-25, 3-39–3-40
Set Printer Font  2-27, 3-29, 3-

40–3-41
signature

adding to message  2-35
changing  2-35, 3-52
creating new  2-33–2-34, 3-51–

3-52
default  2-34, 3-52
deleting  2-35, 3-52–3-53
saving  3-24, 3-27–3-28

signature window  3-22
Signatures  3-50–3-53
signatures  2-33–2-35, 3-18
SMTP  1-14, A-5

setting up  A-6–A-8
status bar  3-8

switching off/on  3-37–3-38
sub-windows  2-3, 3-10–3-22
system requirements  1-3

T
tab stops  3-38
tasks  3-62
template. See form
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text
deselecting  3-36
selecting all  3-36

text encoding  A-7–A-8, B-2, B-
3, B-6

Tile  3-74
toolbar  3-8, 3-23–3-26

switching off/on  3-37
transport configuration  1-8, A-5–

A-12
type handling  A-7–A-8

in message store  A-15

U
Undo  3-32
users, installing  1-5–1-7

V
View menu  3-37–3-42

W
Window menu  3-74–3-75
Windows Sockets  A-5
word wrap  2-26–2-27, 3-19, 3-

41–3-42, 3-64, 3-67–3-68
writing messages  2-4–2-6
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